summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml11
1 files changed, 6 insertions, 5 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 8f380b5..6081cf8 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -2,6 +2,7 @@
name = "rlua"
version = "0.15.3"
authors = ["kyren <catherine@chucklefish.org>"]
+edition = "2018"
description = "High level bindings to Lua 5.3"
repository = "https://github.com/chucklefish/rlua"
documentation = "https://docs.rs/rlua"
@@ -14,17 +15,17 @@ license = "MIT"
[dependencies]
libc = { version = "0.2" }
-failure = { version = "0.1.2" }
num-traits = { version = "0.2.6" }
-compiletest_rs = { version = "0.3", optional = true }
+bstr = {version = "0.2", features = ["std"], default_features = false }
[build-dependencies]
-cc = "1.0"
-pkg-config = "0.3.11"
+cc = { version = "1.0" }
+pkg-config = { version = "0.3.11" }
[dev-dependencies]
-rustyline = "2.0.0"
+rustyline = "5.0"
criterion = "0.2.0"
+compiletest_rs = { version = "0.3", features = ["stable"] }
[[bench]]
name = "benchmark"