summaryrefslogtreecommitdiff
path: root/tests/irc/flood/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/irc/flood/Makefile.am')
-rw-r--r--tests/irc/flood/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/tests/irc/flood/Makefile.am b/tests/irc/flood/Makefile.am
new file mode 100644
index 00000000..4bc4a93c
--- /dev/null
+++ b/tests/irc/flood/Makefile.am
@@ -0,0 +1,32 @@
+include $(top_srcdir)/utils/glib-tap.mk
+
+PACKAGE_STRING=irc/flood
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/src \
+ -I$(top_srcdir)/src/core \
+ -DSYSCONFDIR=\""$(sysconfdir)"\" \
+ $(GLIB_CFLAGS)
+
+test_programs = \
+ test-796
+
+test_796_CPPFLAGS = \
+ -I$(top_srcdir)/src/irc/core \
+ -I$(top_srcdir)/src/irc/flood \
+ $(AM_CPPFLAGS)
+
+test_796_DEPENDENCIES = \
+ ../../../src/core/libcore.a \
+ ../../../src/lib-config/libirssi_config.a
+
+test_796_LDADD = \
+ ../../../src/irc/flood/libirc_flood.a \
+ ../../../src/irc/core/libirc_core.a \
+ ../../../src/core/libcore.a \
+ ../../../src/lib-config/libirssi_config.a \
+ @GLIB_LIBS@ \
+ @OPENSSL_LIBS@
+
+test_796_SOURCES = \
+ test-796.c