summaryrefslogtreecommitdiff
path: root/src/perl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/perl/Makefile.am')
-rw-r--r--src/perl/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/perl/Makefile.am b/src/perl/Makefile.am
index 2e527e70..9f9cc2f9 100644
--- a/src/perl/Makefile.am
+++ b/src/perl/Makefile.am
@@ -44,7 +44,7 @@ noinst_HEADERS = \
xs/module.h
all-local:
- cd xs && if [ ! -f Makefile ]; then $(perlpath) Makefile.PL; fi && $(MAKE) && cd ..
+ cd xs && if [ ! -f Makefile ]; then if [ "x$(PERL_LIB_DIR)" = "x" ]; then $(perlpath) Makefile.PL; else $(perlpath) Makefile.PL LIB=$(PERL_LIB_DIR); fi; fi && $(MAKE) && cd ..
install-exec-local:
cd xs && make install && cd ..