summaryrefslogtreecommitdiff
path: root/src/irc/bot/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/irc/bot/Makefile.am')
-rw-r--r--src/irc/bot/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/irc/bot/Makefile.am b/src/irc/bot/Makefile.am
new file mode 100644
index 00000000..fa7058e7
--- /dev/null
+++ b/src/irc/bot/Makefile.am
@@ -0,0 +1,24 @@
+plugindir = $(libdir)/irssi/plugins
+plugin_LTLIBRARIES = libirc_bot.la
+
+INCLUDES = $(GLIB_CFLAGS) \
+ -I$(top_srcdir)/src -I$(top_srcdir)/src/core/ -I$(top_srcdir)/src/irc/core/
+
+libirc_bot_la_LIBADD = -lcrypt
+
+libirc_bot_la_SOURCES = \
+ bot.c \
+ bot-commands.c \
+ bot-events.c \
+ bot-users.c \
+ botnet.c \
+ botnet-connection.c
+
+noinst_HEADERS = \
+ bot.h \
+ botnet.h \
+ bot-users.h
+
+EXTRA_DIST = \
+ users.sample \
+ botnets.sample