summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index aa6c11ee..eb4b8a4e 100644
--- a/configure.in
+++ b/configure.in
@@ -580,7 +580,15 @@ dnl **
ALL_LINGUAS="pl pt_BR fr de sv"
AM_GNU_GETTEXT
-AM_CONDITIONAL(HAVE_MSGFMT, test "x$MSGFMT" != "xno")
+
+dnl stupid gettext.. we must not leave the po/ dir from SUBDIRS or
+dnl "make dist" doesn't work, and po/Makefile doesn't check if MSGFMT
+dnl exists or not, so instead of failing in po/ dir if there's no msgfmt,
+dnl we just do some stupid echos.
+if test "x$MSGFMT" = "xno"; then
+ MSGFMT=echo
+ GMSGFMT=echo
+fi
dnl ** common libraries needed by frontends
COMMON_NOUI_LIBS="$CHAT_LIBS $CORE_LIBS $INTLLIBS"