summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 4 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 44f28e2d..1282e2fd 100644
--- a/configure.in
+++ b/configure.in
@@ -213,9 +213,6 @@ case "$host_os" in
hpux*)
CFLAGS="$CFLAGS -D_XOPEN_SOURCE_EXTENDED"
;;
- irix*)
- skip_extralibs=true
- ;;
*)
;;
esac
@@ -223,15 +220,17 @@ esac
AC_CHECK_FUNCS(mkfifo fcntl)
-if test "x$skip_extralibs" != "xtrue"; then
+AC_CHECK_FUNC(socket, [], [
AC_CHECK_LIB(socket, socket, [
LIBS="$LIBS -lsocket"
])
+])
+AC_CHECK_FUNC(inet_addr, [], [
AC_CHECK_LIB(nsl, inet_addr, [
LIBS="$LIBS -lnsl"
], -lsocket)
-fi
+])
dnl * gcc specific options
if test "x$ac_cv_prog_gcc" = "xyes"; then