summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index afadddc7..23596412 100644
--- a/configure.in
+++ b/configure.in
@@ -1,5 +1,11 @@
AC_INIT(src)
+# we don't want VERSION in our config.h
+if test -n "`grep '^#undef VERSION' config.h.in`"; then
+ grep -v '^#undef VERSION' config.h.in > config.h.in.temp
+ mv -f config.h.in.temp config.h.in
+fi
+
AM_CONFIG_HEADER(config.h)
AM_INIT_AUTOMAKE(irssi, 0.7.98.CVS)