summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in37
1 files changed, 23 insertions, 14 deletions
diff --git a/configure.in b/configure.in
index 75cf0c0e..8634f0f9 100644
--- a/configure.in
+++ b/configure.in
@@ -100,28 +100,28 @@ else
PERL_LIB_DIR="$prefix"
fi
-AC_ARG_ENABLE(perl-path,
-[ --enable-perl-path=dir Specify where to install the Perl libraries for irssi],
- if test x$enableval = xyes; then
+AC_ARG_WITH(perl-path,
+[ --with-perl-path=dir Specify where to install the Perl libraries for irssi],
+ if test x$withval = xyes; then
want_perl=yes
else
- if test "x$enableval" = xno; then
+ if test "x$withval" = xno; then
want_perl=no
else
want_perl=yes
- PERL_LIB_DIR="$enableval"
+ PERL_LIB_DIR="$withval"
perl_lib_dir_given=yes
fi
fi,
want_perl=yes)
-AC_ARG_ENABLE(perl,
-[ --enable-perl[=yes|no|static] Build with Perl support - also specifies
- if it should be built into main irssi binary
- (static) or as module (default)],
- if test x$enableval = xyes; then
+AC_ARG_WITH(perl,
+[ --with-perl[=yes|no|static] Build with Perl support - also specifies
+ if it should be built into main irssi binary
+ (static) or as module (default)],
+ if test x$withval = xyes; then
want_perl=yes
- elif test x$enableval = xstatic; then
+ elif test x$withval = xstatic; then
want_perl=static
else
want_perl=no
@@ -542,26 +542,35 @@ if test "$want_perl" != "no"; then
if test "x$want_perl" = "xstatic"; then
dnl * building with static perl support
dnl * all PERL_LDFLAGS linking is done in fe-text
- PERL_LDFLAGS="../perl/libperl_static.la $PERL_LDFLAGS"
- PERL_LINK_LIBS="$PERL_LDFLAGS"
+ PERL_LINK_FLAGS="$PERL_LDFLAGS"
+ PERL_LINK_LIBS="../perl/libperl_core_static.la"
+ PERL_FE_LINK_LIBS="../perl/libfe_perl_static.la"
PERL_LDFLAGS=
AC_DEFINE(HAVE_STATIC_PERL)
dnl * build only static library of perl module
perl_module_lib=
- perl_static_lib=libperl_static.la
+ perl_module_fe_lib=
+ perl_static_lib=libperl_core_static.la
+ perl_static_fe_lib=libfe_perl_static.la
PERL_LIBTOOL='$(SHELL) $(top_builddir)/libtool'
else
dnl * build dynamic library of perl module
perl_module_lib=libperl_core.la
+ perl_module_fe_lib=libfe_perl.la
perl_static_lib=
+ perl_static_fe_lib=
PERL_LIBTOOL='$(SHELL) $(top_builddir)/libtool'
fi
AC_SUBST(perl_module_lib)
AC_SUBST(perl_static_lib)
+ AC_SUBST(perl_module_fe_lib)
+ AC_SUBST(perl_static_fe_lib)
AC_SUBST(PERL_LIBTOOL)
+ AC_SUBST(PERL_LINK_FLAGS)
AC_SUBST(PERL_LINK_LIBS)
+ AC_SUBST(PERL_FE_LINK_LIBS)
AC_SUBST(PERL_LDFLAGS)
AC_SUBST(PERL_CFLAGS)