summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 40171a03..29fee0bd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -628,7 +628,7 @@ if test "x$want_ipv6" = "xyes"; then
#include <netinet/in.h>
#include <netdb.h>
#include <arpa/inet.h>],
- [struct in6_addr i;],
+ [struct in6_addr i = in6addr_any; return &i == &i;],
have_ipv6=yes,
)])
if test $have_ipv6 = yes; then