summaryrefslogtreecommitdiff
path: root/src/perl/Makefile.am
diff options
context:
space:
mode:
authorTimo Sirainen <cras@irssi.org>2001-07-30 22:10:11 +0000
committercras <cras@dbcabf3a-b0e7-0310-adc4-f8d773084564>2001-07-30 22:10:11 +0000
commit642622624da6156c6e1c16651aa7970d81e86717 (patch)
treeb76a5bee98c90afb01760985cbdcdd684a30f16f /src/perl/Makefile.am
parent7a7b7a1c1acfb0f72a55a542580bffe50b93f565 (diff)
downloadirssi-642622624da6156c6e1c16651aa7970d81e86717.zip
--with-perl-path -> --with-perl-lib=[site|vendor|DIR] with some fixes to
make it work better. git-svn-id: http://svn.irssi.org/repos/irssi/trunk@1693 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'src/perl/Makefile.am')
-rw-r--r--src/perl/Makefile.am8
1 files changed, 2 insertions, 6 deletions
diff --git a/src/perl/Makefile.am b/src/perl/Makefile.am
index 02073acd..db381053 100644
--- a/src/perl/Makefile.am
+++ b/src/perl/Makefile.am
@@ -15,7 +15,7 @@ perl-core.c: perl-signals-list.h irssi-core.pl.h
INCLUDES = $(GLIB_CFLAGS) \
-DSCRIPTDIR=\""$(libdir)/irssi/scripts"\" \
- -DPERL_LIB_DIR=\""$(PERL_LIB_DIR)"\" \
+ -DPERL_USE_LIB=\""$(PERL_USE_LIB)"\" \
$(PERL_CFLAGS) \
-I$(top_srcdir)/src \
-I$(top_srcdir)/src/core \
@@ -121,11 +121,7 @@ all-local:
for dir in common irc ui; do \
cd $$dir && \
if [ ! -f Makefile ]; then \
- if [ "x$(PERL_LIB_DIR)" = "x" ]; then \
- $(perlpath) Makefile.PL; \
- else \
- $(perlpath) Makefile.PL PREFIX=$(PERL_LIB_DIR) INSTALLDIRS=perl; \
- fi; \
+ $(perlpath) Makefile.PL $(PERL_MM_PARAMS); \
fi && \
($(MAKE) || $(MAKE)) && \
cd ..; \