summaryrefslogtreecommitdiff
path: root/src/perl/Makefile.am
diff options
context:
space:
mode:
authorTimo Sirainen <cras@irssi.org>2001-02-15 00:05:22 +0000
committercras <cras@dbcabf3a-b0e7-0310-adc4-f8d773084564>2001-02-15 00:05:22 +0000
commit187412eb7c7c76f38b20ad53c2971f104d9490d1 (patch)
tree47908ff45b15b4a58a3b0dc706e4eb4bd0b6dfc9 /src/perl/Makefile.am
parent935ec3a9a4627050b983ee13a3eb07c1f111848e (diff)
downloadirssi-187412eb7c7c76f38b20ad53c2971f104d9490d1.zip
Perl 5.6 wants PREFIX=xx, not LIB=xx when default isn't used
git-svn-id: http://svn.irssi.org/repos/irssi/trunk@1216 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'src/perl/Makefile.am')
-rw-r--r--src/perl/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/perl/Makefile.am b/src/perl/Makefile.am
index 5879386c..906fad79 100644
--- a/src/perl/Makefile.am
+++ b/src/perl/Makefile.am
@@ -88,7 +88,7 @@ noinst_HEADERS = \
perl-signals.h
all-local:
- for dir in common irc; do cd $$dir && if [ ! -f Makefile ]; then if [ "x$(PERL_LIB_DIR)" = "x" ]; then $(perlpath) Makefile.PL; else $(perlpath) Makefile.PL LIB=$(PERL_LIB_DIR); fi; fi && if ! $(MAKE); then $(MAKE); fi && cd ..; done
+ for dir in common irc; do cd $$dir && if [ ! -f Makefile ]; then if [ "x$(PERL_LIB_DIR)" = "x" ]; then $(perlpath) Makefile.PL; else $(perlpath) Makefile.PL LIB=$(PERL_LIB_DIR) PREFIX=$(PERL_LIB_DIR); fi; fi && if ! $(MAKE); then $(MAKE); fi && cd ..; done
install-exec-local:
for dir in common irc; do cd $$dir && make install && cd ..; done