summaryrefslogtreecommitdiff
path: root/src/fe-text/Makefile.am
diff options
context:
space:
mode:
authorTimo Sirainen <cras@irssi.org>2001-04-14 22:24:56 +0000
committercras <cras@dbcabf3a-b0e7-0310-adc4-f8d773084564>2001-04-14 22:24:56 +0000
commitadb7eced395ba88816a365768fee56e04a0a0ec5 (patch)
treed4eedd91f292418468acf3eb68aef9bdfe4d3563 /src/fe-text/Makefile.am
parentd98fddd79647e9387ecbf674f317b02f4b78d7e2 (diff)
downloadirssi-adb7eced395ba88816a365768fee56e04a0a0ec5.zip
Rewrote text buffer handling in windows - try #3.
/SET scrollback_save_formats + /SB REDRAW is broken currently. There's some other minor things that might need to be changed. This time it allows the same window to be visible multiple times in screen, like you could make a new split window where to scroll back and find something while still seeing the new messages at the other window, this however doesn't work yet but it should be quite easy to make it :) I've tested that pretty much everything should work with this, new lines can be added at any position and lines can be removed from any position and screen should be updated properly. Screen resizing should also work perfectly now (maybe it did previously too, not sure) and hopefully now we won't see any of those ugly strange bugs some people were having. Also this time the same code isn't written 2-3 times to do some specific thing, like scrolling has now only one view_scroll() function instead of the 3 separate functions it used to have :) git-svn-id: http://svn.irssi.org/repos/irssi/trunk@1442 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'src/fe-text/Makefile.am')
-rw-r--r--src/fe-text/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/src/fe-text/Makefile.am b/src/fe-text/Makefile.am
index 80149f2e..0da9d03e 100644
--- a/src/fe-text/Makefile.am
+++ b/src/fe-text/Makefile.am
@@ -24,17 +24,19 @@ irssi_SOURCES = \
gui-expandos.c \
gui-printtext.c \
gui-readline.c \
- gui-textwidget.c \
gui-windows.c \
lastlog.c \
mainwindows.c \
mainwindow-activity.c \
mainwindows-save.c \
+ screen.c \
statusbar.c \
statusbar-items.c \
+ textbuffer.c \
+ textbuffer-commands.c \
+ textbuffer-view.c \
irssi.c \
- module-formats.c \
- screen.c
+ module-formats.c
noinst_HEADERS = \
gui-entry.h \
@@ -44,5 +46,7 @@ noinst_HEADERS = \
mainwindows.h \
statusbar.h \
screen.h \
+ textbuffer.h \
+ textbuffer-view.h \
module.h \
module-formats.h