summaryrefslogtreecommitdiff
path: root/src/fe-text/Makefile.am
diff options
context:
space:
mode:
authorAlexander Færøy <ahf@0x90.dk>2015-01-04 01:57:21 +0100
committerAlexander Færøy <ahf@irssi.org>2018-02-26 23:32:57 +0100
commit016b42baea9d7dcd2a284f873246c06259c560dd (patch)
tree8c5382398598851bd23b8ca3d439d580f224d684 /src/fe-text/Makefile.am
parentad4324d24210f30646575b8bcbae8b50d2149224 (diff)
downloadirssi-016b42baea9d7dcd2a284f873246c06259c560dd.zip
Add OTR support.
This patch adds support for the OTR protocol to irssi. This is an import of the external irssi-otr project that we are now taking over maintership for. Major thanks to the original authors of Irssi-OTR: Uli Meis and David Goulet. Thanks to the OTR community in #OTR on OFTC, thanks to everyone who have helped testing the patches and submitted UI suggestions.
Diffstat (limited to 'src/fe-text/Makefile.am')
-rw-r--r--src/fe-text/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/fe-text/Makefile.am b/src/fe-text/Makefile.am
index bdd3df22..6ce8427c 100644
--- a/src/fe-text/Makefile.am
+++ b/src/fe-text/Makefile.am
@@ -9,7 +9,8 @@ AM_CPPFLAGS = \
irssi_DEPENDENCIES = \
@COMMON_LIBS@ \
@PERL_LINK_LIBS@ \
- @PERL_FE_LINK_LIBS@
+ @PERL_FE_LINK_LIBS@ \
+ @OTR_LINK_LIBS@
irssi_LDFLAGS = -export-dynamic
@@ -17,6 +18,8 @@ irssi_LDADD = \
@COMMON_LIBS@ \
@PERL_LINK_LIBS@ \
@PERL_FE_LINK_LIBS@ \
+ @OTR_LINK_LIBS@ \
+ @OTR_LINK_FLAGS@ \
@PERL_LINK_FLAGS@ \
@PROG_LIBS@ \
@TEXTUI_LIBS@