summaryrefslogtreecommitdiff
path: root/src/core/Makefile.am
diff options
context:
space:
mode:
authorAlexander Færøy <ahf@0x90.dk>2016-10-16 14:07:22 +0200
committerAlexander Færøy <ahf@0x90.dk>2016-10-22 20:37:33 +0200
commit99d017720dd162122754bfbedc96744f4af8ce6c (patch)
treeac2b8e67bad281e13a7dafe1983539667bfc3076 /src/core/Makefile.am
parent6a286a4eb284cda4dce9ed97fec2aca643a139b0 (diff)
downloadirssi-99d017720dd162122754bfbedc96744f4af8ce6c.zip
Add TLS_REC.
This patch adds the TLS_REC structure. This structure is used to emit information about the TLS handshake from the core of irssi to the front-end layers such that we can display connection information to the user.
Diffstat (limited to 'src/core/Makefile.am')
-rw-r--r--src/core/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/core/Makefile.am b/src/core/Makefile.am
index af323234..10bd035a 100644
--- a/src/core/Makefile.am
+++ b/src/core/Makefile.am
@@ -46,6 +46,7 @@ libcore_a_SOURCES = \
special-vars.c \
utf8.c \
wcwidth.c \
+ tls.c \
write-buffer.c
structure_headers = \
@@ -97,5 +98,6 @@ pkginc_core_HEADERS = \
special-vars.h \
utf8.h \
window-item-def.h \
+ tls.h \
write-buffer.h \
$(structure_headers)