summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorTimo Sirainen <cras@irssi.org>2000-04-28 08:07:42 +0000
committercras <cras@dbcabf3a-b0e7-0310-adc4-f8d773084564>2000-04-28 08:07:42 +0000
commita5a66264de2f56c5b1ba00e0228eae61f70d5689 (patch)
tree981b0663ff753f754cd0204b742ea12bff0d5e56 /src/Makefile.am
parent9cbf26d5199bdd1f3bd29fb27f181af4b94de02e (diff)
downloadirssi-a5a66264de2f56c5b1ba00e0228eae61f70d5689.zip
Perl working again, better than ever (unless there's bugs :)
git-svn-id: http://svn.irssi.org/repos/irssi/trunk@191 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am13
1 files changed, 8 insertions, 5 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index a548c4f4..49aa359d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -3,18 +3,21 @@ TEXTUI=fe-text
endif
if BUILD_GNOMEUI
-GNOMEUI=fe-gnome
+#GNOMEUI=fe-gnome
+GNOMEUI=
endif
if BUILD_IRSSIBOT
BOTUI=fe-none
endif
+if HAVE_PERL
+PERLDIR=perl
+endif
+
noinst_HEADERS = \
nls.h \
common.h \
- common-setup.h \
- irssi-plugin.h \
- irssi-plugin-gui.h
+ common-setup.h
-SUBDIRS = lib-popt lib-config core irc fe-common perl $(GNOMEUI) $(TEXTUI) $(BOTUI)
+SUBDIRS = lib-popt lib-config core irc fe-common $(PERLDIR) $(GNOMEUI) $(TEXTUI) $(BOTUI)