summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTimo Sirainen <cras@irssi.org>2002-12-23 06:44:58 +0000
committercras <cras@dbcabf3a-b0e7-0310-adc4-f8d773084564>2002-12-23 06:44:58 +0000
commitf0eaf349f75adcfd2daf81c18be5662242a6ae67 (patch)
tree915a0109ad8ea4b222336eea99fd51ee22fdefb4 /configure.in
parentb97bc4fe66a9149aae759e43e3ddcbaed52c324b (diff)
downloadirssi-f0eaf349f75adcfd2daf81c18be5662242a6ae67.zip
Check for gc/gc.h too
git-svn-id: http://svn.irssi.org/repos/irssi/trunk@3070 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 0f788a9f..8734e422 100644
--- a/configure.in
+++ b/configure.in
@@ -492,8 +492,12 @@ dnl **
if test "x$want_gc" = xyes; then
if test "$glib_config_major_version" = "2"; then
AC_CHECK_LIB(gc, GC_malloc, [
- AC_DEFINE(HAVE_GC)
- LIBS="$LIBS -lgc"
+ AC_CHECK_HEADER(gc/gc.h, [
+ AC_DEFINE(HAVE_GC)
+ LIBS="$LIBS -lgc"
+ ], [
+ want_gc=no
+ ])
], [
want_gc=no
])