summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAlexander Færøy <ahf@irssi.org>2013-06-23 23:50:14 +0000
committerahf <ahf@dbcabf3a-b0e7-0310-adc4-f8d773084564>2013-06-23 23:50:14 +0000
commitd826896f74925f2e77536d69a3d1a4b86b0cec61 (patch)
tree04b69aa66cddd1076bd1c691816ce16f88dfba32 /configure.in
parent02aa2682dcd6de0defcdc88756dd92e25ae268a4 (diff)
downloadirssi-d826896f74925f2e77536d69a3d1a4b86b0cec61.zip
Implement experimental DNSSEC DANE support
This patch adds experimental support for the DNSSEC DANE verification protocol using the libval library from the DNSSEC-Tools package. Thanks to Thomas Steen Ramussen for creating a test setup and suggesting the idea of experimenting with DANE support in Irssi :-) git-svn-id: file:///var/www/svn.irssi.org/SVN/irssi/trunk@5218 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in21
1 files changed, 21 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index f86d6f9b..cba5d078 100644
--- a/configure.in
+++ b/configure.in
@@ -156,6 +156,15 @@ AC_ARG_ENABLE(ipv6,
fi,
want_ipv6=yes)
+AC_ARG_ENABLE(dane,
+[ --enable-dane Enable DANE support],
+ if test x$enableval = xno ; then
+ want_dane=no
+ else
+ want_dane=yes
+ fi,
+ want_dane=no)
+
dnl **
dnl ** SSL Library checks (OpenSSL)
dnl **
@@ -616,6 +625,17 @@ if test "x$want_ipv6" = "xyes"; then
AC_MSG_RESULT($have_ipv6)
fi
+have_dane=no
+if test "x$want_dane" = "xyes"; then
+ AC_MSG_CHECKING([for DANE])
+ AC_CHECK_LIB(val-threads, val_getdaneinfo,
+ [
+ LIBS="$LIBS -lval-threads -lsres"
+ AC_DEFINE([HAVE_DANE], [], [DANE support])
+ have_dane=yes
+ ])
+fi
+
AC_CONFIG_FILES([
Makefile
src/Makefile
@@ -733,6 +753,7 @@ echo "Building with IPv6 support ....... : $have_ipv6"
echo "Building with SSL support ........ : $have_openssl"
echo "Building with 64bit DCC support .. : $offt_64bit"
echo "Building with garbage collector .. : $have_gc"
+echo "Building with DANE support ....... : $have_dane"
echo
echo "If there are any problems, read the INSTALL file."