summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTimo Sirainen <cras@irssi.org>2002-10-28 00:12:42 +0000
committercras <cras@dbcabf3a-b0e7-0310-adc4-f8d773084564>2002-10-28 00:12:42 +0000
commitba52d084d62a11804759fb5dfebeb67fe534df99 (patch)
tree1a2194a48863b7fd0cb2798c36533aa15cf34c78 /configure.in
parentd58e119a98a534045f9a016e5e41477443ba3b98 (diff)
downloadirssi-ba52d084d62a11804759fb5dfebeb67fe534df99.zip
Try to fix perl compilation for people whose perl has been compiled with
non-GCC but are trying to compile irssi with GCC. git-svn-id: http://svn.irssi.org/repos/irssi/trunk@2976 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 1b64edd6..cf0b412d 100644
--- a/configure.in
+++ b/configure.in
@@ -547,6 +547,16 @@ if test "$want_perl" != "no"; then
PERL_CFLAGS=`$perlpath -MExtUtils::Embed -e ccopts 2>/dev/null`
fi
+ if test "x$ac_cv_prog_gcc" = "xyes" -a ! `echo $host_os|grep -q 'bsd\|linux'`; then
+ dnl * several systems have Perl compiled with native compiler
+ dnl * but irssi is being compiled with GCC. Here we try to
+ dnl * fix those command line options a bit so GCC won't
+ dnl * complain about them. Normally there's only few options
+ dnl * that we want to keep:
+ dnl * -Ddefine -Uundef -I/path -fopt -mopt
+ PERL_CFLAGS=`echo $PERL_CFLAGS | $perlpath -pe 's/^(.* )?-[^DUIfm][^ ]+/\1/g'`
+ fi
+
if test -z "$PERL_CFLAGS"; then
if test -n "$perl_check_error"; then
perl_check_error="Error getting perl CFLAGS"