summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorWouter Coekaerts <coekie@irssi.org>2005-11-03 21:33:32 +0000
committercoekie <coekie@dbcabf3a-b0e7-0310-adc4-f8d773084564>2005-11-03 21:33:32 +0000
commita2637a3ac0598ec45fa60f2d0519f6d5b63bd174 (patch)
tree239b273a40648433f4afd1ae71e534f202cdd90d /configure.in
parenta0a30db4894237d8c94ef8655aea30fc11893cf3 (diff)
downloadirssi-a2637a3ac0598ec45fa60f2d0519f6d5b63bd174.zip
When glib isn't found, download recent glib version (2.8.3) instead of the old 1.2.10
git-svn-id: http://svn.irssi.org/repos/irssi/trunk@4064 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 6 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index 91b3358e..2422d8b1 100644
--- a/configure.in
+++ b/configure.in
@@ -431,21 +431,18 @@ if test -z "$GLIB_DIR"; then
echo "*** Irssi will automatically compile and use it."
echo
- dnl * I think it's pretty safe to assume GLib 1.2.9 since the next
- dnl * will be 2.0 (or 1.4?) and it's not sure if irssi compiles
- dnl * with it (yea, just a few weeks after I put this text for 1.2.8
- dnl * the 1.2.9 came :) .. and then .10
- glib_file=glib-1.2.10.tar.gz
+ glib_url=ftp://ftp.gtk.org/pub/gtk/v2.8/
+ glib_file=glib-2.8.3.tar.gz
dlcmd=
if test -n "`wget --version 2>/dev/null|grep -i wget`"; then
- dlcmd="wget -c ftp://ftp.gtk.org/pub/gtk/v1.2/$glib_file"
+ dlcmd="wget -c $glib_url$glib_file"
elif test -n "`ncftpget --version 2>/dev/null|grep -i ncftp`"; then
- dlcmd="ncftpget -z ftp://ftp.gtk.org/pub/gtk/v1.2/$glib_file"
+ dlcmd="ncftpget -z $glib_url$glib_file"
elif test -n "`lynx --version 2>/dev/null|grep -i lynx`"; then
- dlcmd="lynx --source ftp://ftp.gtk.org/pub/gtk/v1.2/$glib_file > $glib_file"
+ dlcmd="lynx --source $glib_url$glib_file > $glib_file"
elif test -n "`curl --version 2>/dev/null|grep -i curl`"; then
- dlcmd="curl -C - ftp://ftp.gtk.org/pub/gtk/v1.2/$glib_file"
+ dlcmd="curl -C - $glib_url$glib_file"
fi
if test -n "$dlcmd"; then
echo "*** I can download GLib for you now. If you don't want to, press CTRL-C now."