summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authornattfodd <nattfodd@dbcabf3a-b0e7-0310-adc4-f8d773084564>2006-08-08 21:11:20 +0000
committernattfodd <nattfodd@dbcabf3a-b0e7-0310-adc4-f8d773084564>2006-08-08 21:11:20 +0000
commit8b75299729034bd130e06462ebac49158bf58160 (patch)
treeffb7f377f1af402923dd2202536d19605c3af4e0 /configure.in
parentbd3a137c814561bd1a110d1c020350b7de4d10fd (diff)
downloadirssi-8b75299729034bd130e06462ebac49158bf58160.zip
Merge of cuix back in trunk
git-svn-id: http://svn.irssi.org/repos/irssi/trunk@4309 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 343fab37..921ccb37 100644
--- a/configure.in
+++ b/configure.in
@@ -96,6 +96,21 @@ AC_ARG_WITH(terminfo,
fi,
want_terminfo=yes)
+AC_ARG_WITH(ncurses,
+[ --with-ncurses Use curses],
+ if test x$withval = xyes; then
+ want_terminfo=no
+ fi, want_curses=yes)
+
+AC_ARG_WITH(cuix,
+[ --with-cuix Use curses ui extended],
+ if test x$withval = xyes; then
+ want_terminfo=no
+ want_cuix=yes
+ want_curses=yes
+ fi, want_cuix=no)
+
+
AC_ARG_WITH(modules,
[ --with-modules Specify what modules to build in binary],
if test x$withval != xyes -a x$withval != xno; then
@@ -339,6 +354,10 @@ if test "x$want_socks" = "xyes"; then
])
fi
+if test "x$want_cuix" = "xyes"; then
+ AC_DEFINE([HAVE_CUIX], [1] ,[Enable cuix support])
+fi
+
dnl **
dnl ** fe-text checks
dnl **
@@ -808,6 +827,7 @@ AM_CONDITIONAL(HAVE_PERL, test "$want_perl" != "no")
AM_CONDITIONAL(HAVE_STATIC_PERL, test "$want_perl" = "static")
AM_CONDITIONAL(NEED_TPARM, test "$need_tparm" = "yes")
AM_CONDITIONAL(USE_CURSES, test "$want_terminfo" != "yes" -a "$want_termcap" != "yes")
+AM_CONDITIONAL(USE_CUIX, test "$want_cuix" = "yes")
# move LIBS to PROG_LIBS so they're not tried to be used when linking eg. perl libraries
PROG_LIBS=$LIBS