summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTimo Sirainen <cras@irssi.org>2002-12-23 06:24:54 +0000
committercras <cras@dbcabf3a-b0e7-0310-adc4-f8d773084564>2002-12-23 06:24:54 +0000
commit76299b7cee690cd667d49a63d30e582ccfd0ec21 (patch)
treee06f3840ef44a1c3fd42546f32aa7b644bfd46e0 /configure.in
parent2a8e1b5251b9a1a530adfaa219e5761c4d9f0338 (diff)
downloadirssi-76299b7cee690cd667d49a63d30e582ccfd0ec21.zip
some weird changes reverted
git-svn-id: http://svn.irssi.org/repos/irssi/trunk@3065 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in59
1 files changed, 0 insertions, 59 deletions
diff --git a/configure.in b/configure.in
index 0a369a44..a4ebfcb4 100644
--- a/configure.in
+++ b/configure.in
@@ -233,63 +233,6 @@ AC_ARG_WITH(openssl-libs,
[openssl_prefix=/usr/lib])
dnl **
-dnl ** SSL Library checks (OpenSSL)
-dnl **
-
-AC_ARG_ENABLE(ssl,
- [ --enable-ssl Turn on Secure Sockets Layer support [default=yes]],,
- enable_ssl=yes)
-
-AC_ARG_WITH(openssl-includes,
- [ --with-openssl-includes Specify location of OpenSSL header files],
- [openssl_inc_prefix=-I$withval])
-
-AC_ARG_WITH(openssl-libs,
- [ --with-openssl-libs Specify location of OpenSSL libs],
- [openssl_prefix=$withval],
- [openssl_prefix=/usr/lib])
-
-if test "x$enable_ssl" = xyes; then
- ###
- ### Check for OpenSSL
- ###
- save_CFLAGS=$CFLAGS;
- CFLAGS="-lcrypto";
-
- enable_openssl="no";
- OPENSSL_LDFLAGS="";
- AC_CHECK_LIB(ssl, SSL_read,
- AC_CHECK_LIB(crypto, X509_new,
- AC_CHECK_HEADERS(openssl/ssl.h openssl/err.h,
- [
- enable_openssl="yes";
- OPENSSL_LDFLAGS="-lssl -lcrypto"
- ],
- AC_ERROR([Cannot find OpenSSL includes !])),
- AC_ERROR([Cannot find libCrypto !])),
- AC_ERROR([Cannot find libSSL !]))
- CFLAGS=$save_CFLAGS
-
- if test "x$enable_openssl" = xyes; then
- AC_DEFINE(HAVE_OPENSSL)
- OPENSSL_LIBS="-L$openssl_prefix $OPENSSL_LDFLAGS"
- OPENSSL_CFLAGS="$openssl_inc_prefix"
- enable_openssl="yes, in $openssl_prefix"
- else
- OPENSSL_LIBS=
- OPENSSL_CFLAGS=
- fi
-
- AC_SUBST(OPENSSL_CFLAGS)
- AC_SUBST(OPENSSL_LIBS)
- LIBS="$LIBS $OPENSSL_LIBS"
- CFLAGS="$CFLAGS $OPENSSL_CFLAGS"
-else
- enable_openssl="no"
-fi
-
-
-dnl **
dnl ** just some generic stuff...
dnl **
@@ -960,8 +903,6 @@ if test "x$want_ipv6" = "xyes"; then
AC_MSG_RESULT($irssi_cv_type_in6_addr)
fi
-echo "OpenSSL support .............: ${enable_openssl}"
-
dnl **
dnl ** IRSSI_VERSION_DATE and IRSSI_VERSION_TIME
dnl **