summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTimo Sirainen <cras@irssi.org>1999-10-02 10:29:01 +0000
committercras <cras@dbcabf3a-b0e7-0310-adc4-f8d773084564>1999-10-02 10:29:01 +0000
commit5b96b49e38b9df673ce27eb3da0042633a4d642b (patch)
treee87fb58cde362c073fa391d3910ea2ad5300eaab /configure.in
parenta14ebfc9c3da7ac28460b0b6dbcb7d3d2667e248 (diff)
downloadirssi-5b96b49e38b9df673ce27eb3da0042633a4d642b.zip
--without-bot to configure doesn't build irssi-bot
git-svn-id: http://svn.irssi.org/repos/irssi/trunk@30 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index b572d447..7cf531e9 100644
--- a/configure.in
+++ b/configure.in
@@ -74,6 +74,19 @@ AC_ARG_WITH(textui,
fi,
want_textui=yes)
+AC_ARG_WITH(bot,
+[ --with-bot Build irssi-bot],
+ if test x$withval = xyes; then
+ want_irssibot=yes
+ else
+ if test "x$withval" = xno; then
+ want_irssibot=no
+ else
+ want_irssibot=yes
+ fi
+ fi,
+ want_irssibot=yes)
+
AC_ARG_WITH(plugins,
[ --with-plugins Build plugins],
if test x$withval = xyes; then
@@ -303,6 +316,9 @@ else
fi
AM_CONDITIONAL(HAS_CURSES, test "$has_curses" = true)
+dnl ** check if we want to build irssibot
+AM_CONDITIONAL(BUILD_IRSSIBOT, test "$want_irssibot" = true)
+
dnl **
dnl ** memory debugging
dnl **