summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorEmanuele Giaquinta <exg@irssi.org>2007-06-17 22:13:24 +0000
committerexg <exg@dbcabf3a-b0e7-0310-adc4-f8d773084564>2007-06-17 22:13:24 +0000
commit5a433f43598e6f1cc0d57bcb07cd90150533881e (patch)
tree85867b19ab3d750c6bf563016cdd8206abc3dac6 /configure.in
parent9e57a69b4c33940af795dc3c5de1a5b38ff88214 (diff)
downloadirssi-5a433f43598e6f1cc0d57bcb07cd90150533881e.zip
More accurate reporting of enabled/disabled features.
git-svn-id: http://svn.irssi.org/repos/irssi/trunk@4566 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in28
1 files changed, 14 insertions, 14 deletions
diff --git a/configure.in b/configure.in
index e48a01e1..a89b285e 100644
--- a/configure.in
+++ b/configure.in
@@ -336,21 +336,22 @@ fi
LIBS="$LIBS $GLIB_LIBS"
+have_openssl=no
if test "$enable_ssl" = "yes"; then
if pkg-config --exists openssl; then
PKG_CHECK_MODULES(SSL, openssl)
CFLAGS="$CFLAGS $SSL_CFLAGS"
- enable_openssl=yes
+ have_openssl=yes
else
AC_CHECK_LIB(ssl, SSL_read, [
AC_CHECK_HEADERS(openssl/ssl.h openssl/err.h, [
SSL_LIBS="-lssl -lcrypto"
AC_SUBST(SSL_LIBS)
- enable_openssl=yes
+ have_openssl=yes
])
],, -lcrypto)
fi
- if test "$enable_openssl" = "yes"; then
+ if test "$have_openssl" = "yes"; then
AC_DEFINE(HAVE_OPENSSL,, Build with OpenSSL support)
LIBS="$LIBS $SSL_LIBS"
fi
@@ -359,23 +360,22 @@ fi
dnl **
dnl ** Garbage Collector
dnl **
+have_gc=no
if test "x$want_gc" = xyes; then
AC_CHECK_LIB(gc, GC_malloc, [
AC_CHECK_HEADER(gc/gc.h, [
AC_DEFINE(HAVE_GC_GC_H)
AC_DEFINE(USE_GC)
LIBS="$LIBS -lgc"
+ have_gc=yes
], [
AC_CHECK_HEADER(gc.h, [
AC_DEFINE(HAVE_GC_H)
AC_DEFINE(USE_GC)
LIBS="$LIBS -lgc"
- ], [
- want_gc=no
+ have_gc=yes
])
])
- ], [
- want_gc=no
])
fi
@@ -747,6 +747,7 @@ dnl **
dnl ** IPv6 support
dnl **
+have_ipv6=no
if test "x$want_ipv6" = "xyes"; then
AC_MSG_CHECKING([for IPv6])
AC_CACHE_VAL(irssi_cv_type_in6_addr,
@@ -757,13 +758,12 @@ if test "x$want_ipv6" = "xyes"; then
#include <netdb.h>
#include <arpa/inet.h>],
[struct in6_addr i;],
- irssi_cv_type_in6_addr=yes,
- irssi_cv_type_in6_addr=no,
+ have_ipv6=yes,
)])
- if test $irssi_cv_type_in6_addr = yes; then
+ if test $have_ipv6 = yes; then
AC_DEFINE(HAVE_IPV6)
fi
- AC_MSG_RESULT($irssi_cv_type_in6_addr)
+ AC_MSG_RESULT($have_ipv6)
fi
dnl **
@@ -891,10 +891,10 @@ echo "Install prefix ................... : $prefix"
echo
-echo "Building with IPv6 support ....... : $want_ipv6"
-echo "Building with SSL support ........ : ${enable_openssl}"
+echo "Building with IPv6 support ....... : $have_ipv6"
+echo "Building with SSL support ........ : $have_openssl"
echo "Building with 64bit DCC support .. : $offt_64bit"
-echo "Building with garbage collector .. : $want_gc"
+echo "Building with garbage collector .. : $have_gc"
echo
echo "If there are any problems, read the INSTALL file."