summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTimo Sirainen <cras@irssi.org>2001-02-21 03:43:31 +0000
committercras <cras@dbcabf3a-b0e7-0310-adc4-f8d773084564>2001-02-21 03:43:31 +0000
commit5001f8cd7ac83e638442da0542417d724b823e67 (patch)
tree058bcfffb6ef4e89057ab5c769fc8fcb796b64f3 /configure.in
parent481f4bc32720e939504916cbd53447110b739551 (diff)
downloadirssi-5001f8cd7ac83e638442da0542417d724b823e67.zip
Changed some s/// to use perl instead of sed since they didn't work
with all seds. git-svn-id: http://svn.irssi.org/repos/irssi/trunk@1269 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 3564cb29..0dc61ba4 100644
--- a/configure.in
+++ b/configure.in
@@ -416,7 +416,7 @@ if test "$want_perl" != "no"; then
if test "$want_perl" != "static"; then
dnl * dynaloader.a -> libperl_dynaloader.la
- DYNALOADER_A=`echo $PERL_LDFLAGS | $sedpath 's/^\(.* \)*\([[^ ]]*DynaLoader\.a\).*/\2/'`
+ DYNALOADER_A=`echo $PERL_LDFLAGS | $perlpath -pe 's/^(.* )*([[^ ]]*DynaLoader\.a).*/\2/'`
fi
dnl * don't check libperl.a if dynaloader.a wasn't found..
@@ -456,7 +456,7 @@ if test "$want_perl" != "no"; then
want_perl=static
else
AC_MSG_RESULT(ok)
- PERL_LDFLAGS=`echo $PERL_LDFLAGS | $sedpath 's/^\(.* \)*[[^ ]]*DynaLoader\.a/\1libperl_dynaloader.la/'`
+ PERL_LDFLAGS=`echo $PERL_LDFLAGS | $perlpath -pe 's/^(.* )*[[^ ]]*DynaLoader\.a/\1libperl_dynaloader.la/'`
if test "x$LIBPERL_A" != "x"; then
PERL_LDFLAGS=`echo $PERL_LDFLAGS | $sedpath 's/ -lperl/ libperl_orig.la/'`
fi