summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTimo Sirainen <cras@irssi.org>2003-01-14 20:12:38 +0000
committercras <cras@dbcabf3a-b0e7-0310-adc4-f8d773084564>2003-01-14 20:12:38 +0000
commit4ef3baec32aac34aa4d315e6e15911effea36399 (patch)
treee87fda223d688472a619e2d2fdf2ddcc769bc89d /configure.in
parentb687ace2b11169e2c4dd864152794a086486315d (diff)
downloadirssi-4ef3baec32aac34aa4d315e6e15911effea36399.zip
Added --with-glib1
git-svn-id: http://svn.irssi.org/repos/irssi/trunk@3096 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in22
1 files changed, 20 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index b148d751..459c1466 100644
--- a/configure.in
+++ b/configure.in
@@ -124,6 +124,19 @@ AC_ARG_WITH(gc,
fi,
want_gc=no)
+AC_ARG_WITH(glib1,
+[ --with-glib1 Use GLIB 1.2 instead of 2.0 if both exist],
+ if test x$withval = xyes; then
+ want_glib1=yes
+ else
+ if test "x$withval" = xno; then
+ want_glib1=no
+ else
+ want_glib1=yes
+ fi
+ fi,
+ want_glib1=no)
+
AC_ARG_WITH(perl-staticlib,
[ --with-perl-staticlib Specify that we want to link perl libraries
statically in irssi, default is no],
@@ -388,8 +401,13 @@ AC_DEFUN(AC_CHECK_GLIBDIR,[
AC_CHECK_GLIBDIR
if test -z "$GLIB_DIR"; then
- dnl * check glib1 then glib2
- checks="3 4 1 2"
+ if test "x$with_glib1" = "xyes"; then
+ dnl * check only for glib1
+ checks="1 2"
+ else
+ dnl * check glib2 then glib1
+ checks="3 4 1 2"
+ fi
for try in $checks; do
glib_config_args=