summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTimo Sirainen <cras@irssi.org>1999-10-30 13:21:14 +0000
committercras <cras@dbcabf3a-b0e7-0310-adc4-f8d773084564>1999-10-30 13:21:14 +0000
commit4d584944436bc68beff2b0f4f8f0542769a91ba5 (patch)
treef3722daab04982be722027d9a0199af2045f2180 /configure.in
parent4d32f9aea6a15e4924516e1bde1ccb64bb8fb4fd (diff)
downloadirssi-4d584944436bc68beff2b0f4f8f0542769a91ba5.zip
Internationalization works now.
git-svn-id: http://svn.irssi.org/repos/irssi/trunk@67 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in38
1 files changed, 13 insertions, 25 deletions
diff --git a/configure.in b/configure.in
index 640987ce..e770b2c2 100644
--- a/configure.in
+++ b/configure.in
@@ -172,17 +172,6 @@ if test "x$ac_cv_prog_gcc" = "xyes"; then
CFLAGS="$CFLAGS -Wall"
fi
-if test "x$prefix" = "xNONE"; then
- prefix="/usr/local"
-else
- prefix=$prefix
-fi
-
-AM_CONDITIONAL(BUILD_PLUGINS, test "x$want_plugins" = "xyes")
-AM_CONDITIONAL(BUILD_SERVERTEST, test "x$want_servertest" = "xyes")
-AC_DEFINE_UNQUOTED(SYSCONFDIR, "$prefix/etc")
-AC_DEFINE_UNQUOTED(PLUGINSDIR, "$prefix/lib/irssi/plugins")
-
dnl **
dnl ** check for libPropList
dnl **
@@ -233,7 +222,6 @@ if test "x$want_gnome" = "xyes"; then
fi
fi
-AM_CONDITIONAL(HAVE_GNOME, test "x$want_gnome" = "xyes")
if test "x$want_gnome" = "xyes"; then
AC_DEFINE(HAVE_GTK)
AC_DEFINE(HAVE_GNOME)
@@ -280,8 +268,6 @@ fi
AC_SUBST(GUI_LIBS)
AC_SUBST(GUI_CFLAGS)
-AM_CONDITIONAL(BUILD_GNOMEUI, test "x$GUI_LIBS" != "x")
-AM_CONDITIONAL(HAVE_GNOME_PANEL, test "x$want_gnome_panel" = "xyes")
dnl **
@@ -290,6 +276,9 @@ dnl **
AM_PATH_GLIB(1.2.0,,, gmodule)
+PROG_LIBS="$PROG_LIBS $GLIB_LIBS ../lib-popt/libpopt.a"
+AC_SUBST(PROG_LIBS)
+
dnl **
dnl ** curses checks
dnl **
@@ -314,8 +303,13 @@ else
fi
AM_CONDITIONAL(HAS_CURSES, test "$has_curses" = true)
-dnl ** check if we want to build irssibot
+dnl ** check what we want to build
AM_CONDITIONAL(BUILD_IRSSIBOT, test "$want_irssibot" = "xyes")
+AM_CONDITIONAL(BUILD_PLUGINS, test "x$want_plugins" = "xyes")
+AM_CONDITIONAL(BUILD_SERVERTEST, test "x$want_servertest" = "xyes")
+AM_CONDITIONAL(BUILD_GNOMEUI, test "x$GUI_LIBS" != "x")
+AM_CONDITIONAL(HAVE_GNOME, test "x$want_gnome" = "xyes")
+AM_CONDITIONAL(HAVE_GNOME_PANEL, test "x$want_gnome_panel" = "xyes")
dnl **
dnl ** memory debugging
@@ -334,23 +328,17 @@ if test "x$want_ipv6" = "xyes"; then
AC_DEFINE(HAVE_IPV6)
fi
-PROG_LIBS="$PROG_LIBS $GLIB_LIBS ../lib-popt/libpopt.a"
-AC_SUBST(PROG_LIBS)
-
-
dnl **
dnl ** internationalization support
dnl **
-dnl ALL_LINGUAS=""
-dnl AM_GNU_GETTEXT
-dnl AC_LINK_FILES($nls_cv_header_libgt, $nls_cv_header_intl)
+ALL_LINGUAS="fi"
+AM_GNU_GETTEXT
AC_OUTPUT(
Makefile
-dnl ## internationalization support
-dnl po/Makefile.in
-dnl intl/Makefile
+po/Makefile.in
+intl/Makefile
macros/Makefile
src/Makefile
src/irc-base/Makefile