summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTimo Sirainen <cras@irssi.org>2003-01-25 03:19:40 +0000
committercras <cras@dbcabf3a-b0e7-0310-adc4-f8d773084564>2003-01-25 03:19:40 +0000
commit0e61b4c8296d554065d934a4a0c27bed8603d3de (patch)
tree11041d8560a2cc69ba8aae34b4ef8b26a47203f5 /configure.in
parent8fe52e204147fcda0699badc2b1511e9c456ef97 (diff)
downloadirssi-0e61b4c8296d554065d934a4a0c27bed8603d3de.zip
Lets see if GC happens to work now without explicit free() calls. Perl
objects now set the C pointer to NULL once they're done with it, so this might just work without leaking.. git-svn-id: http://svn.irssi.org/repos/irssi/trunk@3101 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 459c1466..c048c4a2 100644
--- a/configure.in
+++ b/configure.in
@@ -512,10 +512,12 @@ if test "x$want_gc" = xyes; then
AC_CHECK_LIB(gc, GC_malloc, [
AC_CHECK_HEADER(gc/gc.h, [
AC_DEFINE(HAVE_GC_GC_H)
+ AC_DEFINE(USE_GC)
LIBS="$LIBS -lgc"
], [
AC_CHECK_HEADER(gc.h, [
AC_DEFINE(HAVE_GC_H)
+ AC_DEFINE(USE_GC)
LIBS="$LIBS -lgc"
], [
want_gc=no