summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorEmanuele Giaquinta <exg@irssi.org>2007-12-05 23:13:53 +0000
committerexg <exg@dbcabf3a-b0e7-0310-adc4-f8d773084564>2007-12-05 23:13:53 +0000
commitdc8e204bd9b54a96e37aa931027bd7f0a1160ce0 (patch)
treeb5ef91854e3a065e5e94a72f32dc10c6bb8d9e6c /configure.in
parentb58049a8a12c798804e52e1cc6a03eea7e36e66a (diff)
downloadirssi-dc8e204bd9b54a96e37aa931027bd7f0a1160ce0.zip
Tabify.
git-svn-id: http://svn.irssi.org/repos/irssi/trunk@4655 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in46
1 files changed, 23 insertions, 23 deletions
diff --git a/configure.in b/configure.in
index 74b26fd8..1647756e 100644
--- a/configure.in
+++ b/configure.in
@@ -100,7 +100,7 @@ AC_ARG_WITH(modules,
fi)
if test "x$prefix" != "xNONE"; then
- prefix=`eval echo $prefix`
+ prefix=`eval echo $prefix`
PERL_MM_PARAMS="INSTALLDIRS=perl PREFIX=$prefix"
perl_library_dir="PERL_USE_LIB"
perl_set_use_lib=yes
@@ -339,7 +339,7 @@ if test "$want_ssl" = "yes"; then
else
AC_CHECK_LIB(ssl, SSL_read, [
AC_CHECK_HEADERS(openssl/ssl.h openssl/err.h, [
- SSL_LIBS="-lssl -lcrypto"
+ SSL_LIBS="-lssl -lcrypto"
have_openssl=yes
])
],, -lcrypto)
@@ -446,7 +446,7 @@ if test "x$want_textui" = "xyes"; then
AC_CHECK_FUNC(wresize, AC_DEFINE(HAVE_CURSES_WRESIZE))
fi
AC_CHECK_FUNC(setupterm,, [
- want_termcap=yes
+ want_termcap=yes
])
LIBS=$old_libs
else
@@ -463,14 +463,14 @@ if test "x$want_textui" = "xyes"; then
AC_ERROR(Terminfo/termcap not found - install ncurses-devel package)
want_textui=no
])))
- fi
+ fi
AC_SUBST(TEXTUI_LIBS)
- if test "x$want_termcap" = "xyes"; then
- AC_CHECK_FUNC(tparm,, need_tparm=yes)
+ if test "x$want_termcap" = "xyes"; then
+ AC_CHECK_FUNC(tparm,, need_tparm=yes)
else
AC_DEFINE(HAVE_TERMINFO)
- fi
+ fi
fi
dnl **
@@ -481,7 +481,7 @@ if test "$want_perl" != "no"; then
AC_MSG_CHECKING(for working Perl support)
if test -z "$perlpath"; then
- perl_check_error="perl binary not found"
+ perl_check_error="perl binary not found"
else
PERL_CFLAGS=`$perlpath -MExtUtils::Embed -e ccopts 2>/dev/null`
fi
@@ -511,7 +511,7 @@ if test "$want_perl" != "no"; then
dnl * Perl 5.004 and older use perl_xxx variables while
dnl * later use PL_perl_xxx variables ..
have_pl_perl=`$perlpath -e 'print $] < 5.005 ? "no" : "yes";'`
- if test "x$have_pl_perl" = "xyes"; then
+ if test "x$have_pl_perl" = "xyes"; then
AC_DEFINE(HAVE_PL_PERL)
fi
@@ -637,7 +637,7 @@ if test "$want_perl" != "no"; then
AC_SUBST(PERL_LINK_FLAGS)
AC_SUBST(PERL_LINK_LIBS)
- AC_SUBST(PERL_FE_LINK_LIBS)
+ AC_SUBST(PERL_FE_LINK_LIBS)
AC_SUBST(PERL_LDFLAGS)
AC_SUBST(PERL_CFLAGS)
@@ -705,25 +705,25 @@ for c in $CHAT_MODULES; do
mkdir -p src/$c
file="src/$c/$c.c"
- echo "/* this file is automatically generated by configure - don't change */" > $file
+ echo "/* this file is automatically generated by configure - don't change */" > $file
echo "void ${c}_core_init(void); void ${c}_core_deinit(void);" >> $file
if test -n "$module_inits"; then
- echo "$module_inits" | $sedpath -e 's/()/(void)/g' -e 's/ /void /g' >> $file
- echo "$module_deinits" | $sedpath -e 's/ *$//' -e 's/()/(void)/g' -e 's/ /void /g' -e 's/^/void /' >> $file
+ echo "$module_inits" | $sedpath -e 's/()/(void)/g' -e 's/ /void /g' >> $file
+ echo "$module_deinits" | $sedpath -e 's/ *$//' -e 's/()/(void)/g' -e 's/ /void /g' -e 's/^/void /' >> $file
fi
- echo "void ${c}_init(void) { ${c}_core_init(); $module_inits }" >> $file
- echo "void ${c}_deinit(void) { $module_deinits ${c}_core_deinit(); }" >> $file
+ echo "void ${c}_init(void) { ${c}_core_init(); $module_inits }" >> $file
+ echo "void ${c}_deinit(void) { $module_deinits ${c}_core_deinit(); }" >> $file
if test -f $srcdir/src/fe-common/$c/module.h; then
mkdir -p src/fe-common/$c
- file="src/fe-common/$c/${c}-modules.c"
- echo "/* this file is automatically generated by configure - don't change */" > $file
- if test -n "$fe_module_inits"; then
- echo "$fe_module_inits" | $sedpath -e 's/()/(void)/g' -e 's/ /void /g' >> $file
- echo "$fe_module_deinits" | $sedpath -e 's/ *$//' -e 's/()/(void)/g' -e 's/ /void /g' -e 's/^/void /' >> $file
+ file="src/fe-common/$c/${c}-modules.c"
+ echo "/* this file is automatically generated by configure - don't change */" > $file
+ if test -n "$fe_module_inits"; then
+ echo "$fe_module_inits" | $sedpath -e 's/()/(void)/g' -e 's/ /void /g' >> $file
+ echo "$fe_module_deinits" | $sedpath -e 's/ *$//' -e 's/()/(void)/g' -e 's/ /void /g' -e 's/^/void /' >> $file
fi
- echo "void fe_${c}_modules_init(void) { $fe_module_inits }" >> $file
- echo "void fe_${c}_modules_deinit(void) { $fe_module_deinits }" >> $file
+ echo "void fe_${c}_modules_init(void) { $fe_module_inits }" >> $file
+ echo "void fe_${c}_modules_deinit(void) { $fe_module_deinits }" >> $file
fi
done
@@ -870,7 +870,7 @@ if test "x$want_perl" != "xno"; then
if test -z "$perl_library_dir"; then
perl_library_dir="(site default - `$perlpath -e 'use Config; print $Config{sitearch}'`)"
fi
- echo "Perl library directory ........... : $perl_library_dir"
+ echo "Perl library directory ........... : $perl_library_dir"
if test "x$perl_prefix_note" = "xyes"; then
echo " - NOTE: This was automatically set to the same directory you gave with"
echo " --prefix. If you want the perl libraries to install to their 'correct'"