summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTimo Sirainen <cras@irssi.org>2001-05-17 20:13:59 +0000
committercras <cras@dbcabf3a-b0e7-0310-adc4-f8d773084564>2001-05-17 20:13:59 +0000
commitc2b2d45bd62ce410ba7ca8ac920d340b9ed1a527 (patch)
tree0d8256390680d8b7c34b9e294d9749e69db195c8 /configure.in
parentfe5c94b050650c8b8f20278ea413fb1cc8d093dc (diff)
downloadirssi-c2b2d45bd62ce410ba7ca8ac920d340b9ed1a527.zip
Getting rid of gettext, moved some _(..) texts to themes and left some error
messages hard coded. git-svn-id: http://svn.irssi.org/repos/irssi/trunk@1503 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in19
1 files changed, 1 insertions, 18 deletions
diff --git a/configure.in b/configure.in
index a0649061..849a2efe 100644
--- a/configure.in
+++ b/configure.in
@@ -364,6 +364,7 @@ cat > conftest.c <<EOF
#include <math.h>
int modfunc(void){return (int)floor(1.2);}
EOF
+
./libtool --mode=compile $CC $CFLAGS -c conftest.c 2> /dev/null > /dev/null
if test ! -s conftest.lo; then
AC_ERROR([error compiling test module])
@@ -667,22 +668,6 @@ done
FE_COMMON_LIBS="$FE_COMMON_LIBS../fe-common/core/libfe_common_core.a"
-dnl **
-dnl ** internationalization support
-dnl **
-
-ALL_LINGUAS="pl pt_BR fr de sv"
-AM_GNU_GETTEXT
-
-dnl stupid gettext.. we must not leave the po/ dir from SUBDIRS or
-dnl "make dist" doesn't work, and po/Makefile doesn't check if MSGFMT
-dnl exists or not, so instead of failing in po/ dir if there's no msgfmt,
-dnl we just do some stupid echos.
-if test "x$MSGFMT" = "xno"; then
- MSGFMT=echo
- GMSGFMT=echo
-fi
-
dnl ** common libraries needed by frontends
COMMON_NOUI_LIBS="$CHAT_LIBS $CORE_LIBS $INTLLIBS"
COMMON_LIBS="$FE_COMMON_LIBS $COMMON_NOUI_LIBS"
@@ -716,8 +701,6 @@ fi
AC_OUTPUT(
Makefile
-po/Makefile.in
-intl/Makefile
src/Makefile
src/core/Makefile
src/irc/Makefile