summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTimo Sirainen <cras@irssi.org>2002-12-23 06:39:26 +0000
committercras <cras@dbcabf3a-b0e7-0310-adc4-f8d773084564>2002-12-23 06:39:26 +0000
commitb97bc4fe66a9149aae759e43e3ddcbaed52c324b (patch)
tree88f1bf8e09d8c0a56c9473f534c0d7d84f3f646a /configure.in
parent9e6ee33cdfc1386131363455194fa0c5c77cc8d8 (diff)
downloadirssi-b97bc4fe66a9149aae759e43e3ddcbaed52c324b.zip
If ignore_perl_errors environment is set, we don't check if we could
actually compile perl test program at runtime. Kludge to fix some broken perl installations.. git-svn-id: http://svn.irssi.org/repos/irssi/trunk@3069 dbcabf3a-b0e7-0310-adc4-f8d773084564
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index a91c1f9a..0f788a9f 100644
--- a/configure.in
+++ b/configure.in
@@ -691,7 +691,7 @@ if test "$want_perl" != "no"; then
dnl * check that perl's ldflags actually work
echo "main(){perl_alloc(); return 0;}" > conftest.c
$CC $CFLAGS conftest.c -o conftest $LDFLAGS $PERL_LDFLAGS 2> perl.error.tmp > /dev/null
- if test ! -s conftest; then
+ if test ! -s conftest -a "x$ignore_perl_errors" = "x"; then
perl_check_error="Error linking with perl libraries: $PERL_LDFLAGS: `cat perl.error.tmp`"
AC_MSG_RESULT([error linking with perl libraries, building without Perl])
want_perl=no