summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorailin-nemui <ailin-nemui@users.noreply.github.com>2017-01-03 12:45:27 +0100
committerGitHub <noreply@github.com>2017-01-03 12:45:27 +0100
commit5787e2b4befb61585fc312843bd7a5efd0101dce (patch)
treec0073992aa598692aceffa8a10a4695cdb068585 /configure.ac
parent91f48c6f0e03e53c0968a5433d672ea966006e59 (diff)
parent1f72b8e66a06b484dde20b6031c766a2129e0bd2 (diff)
downloadirssi-5787e2b4befb61585fc312843bd7a5efd0101dce.zip
Merge pull request #412 from LemonBoy/pcre-regexp
Use GLib's regexp interface (backed by PCRE)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 17 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index bf87f5aa..8d588408 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,7 +21,7 @@ AC_PATH_PROG(perlpath, perl)
AC_CHECK_HEADERS(unistd.h dirent.h sys/ioctl.h sys/resource.h)
# check posix headers..
-AC_CHECK_HEADERS(sys/socket.h sys/time.h sys/utsname.h regex.h)
+AC_CHECK_HEADERS(sys/socket.h sys/time.h sys/utsname.h)
AC_SYS_LARGEFILE
@@ -144,6 +144,15 @@ AC_ARG_ENABLE(true-color,
fi,
want_truecolor=no)
+AC_ARG_ENABLE(gregex,
+[ --disable-gregex Build without GRegex (fall back to regex.h)],
+ if test x$enableval = xno ; then
+ want_gregex=no
+ else
+ want_gregex=yes
+ fi,
+ want_gregex=yes)
+
dnl **
dnl ** just some generic stuff...
dnl **
@@ -534,6 +543,12 @@ else
want_truecolor=no
fi
+if test "x$want_gregex" = "xyes"; then
+ AC_DEFINE([USE_GREGEX], [], [use GRegex for regular expressions])
+else
+ want_gregex=no
+fi
+
AH_TEMPLATE(HAVE_GMODULE)
AH_TEMPLATE(HAVE_SOCKS_H, [misc..])
AH_TEMPLATE(HAVE_STATIC_PERL)
@@ -648,6 +663,7 @@ echo
echo "Building with 64bit DCC support .. : $offt_64bit"
echo "Building with true color support.. : $want_truecolor"
+echo "Building with GRegex ............. : $want_gregex"
echo
echo "If there are any problems, read the INSTALL file."