diff options
author | Nick Gerace <nickagerace@gmail.com> | 2020-08-31 18:35:28 -0400 |
---|---|---|
committer | Nick Gerace <39320683+nickgerace@users.noreply.github.com> | 2020-08-31 18:45:19 -0400 |
commit | d3227a0e9e329e91e3b001cad2797884ad3f3104 (patch) | |
tree | baf8f3484c0c3a701db3e67c1683793a4c856c1f /Cargo.toml | |
parent | 3537ddde312ef83f4dd2a57c7d867f5ebf53cfe5 (diff) | |
download | gfold-d3227a0e9e329e91e3b001cad2797884ad3f3104.zip |
Switch to structopt for CLI parsing, and change path flag to positional argument
Switch from clap to structopt for the CLI library of choice. This is
because we were using unversioned clap at its latest main branch
release. Structopt will provide us with concrete version support until
clap v3 releases, or we stay with structopt. We also change the
"-p/--path" flag to an optional, positional argument with this commit.
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 6 |
1 files changed, 3 insertions, 3 deletions
@@ -5,6 +5,6 @@ authors = ["Nick Gerace <nickagerace@gmail.com>"] edition = "2018"
[dependencies]
-clap = { git = "https://github.com/clap-rs/clap/" }
-git2 = "^0.13"
-prettytable-rs = "^0.8"
+structopt = "0.3"
+git2 = "0.13"
+prettytable-rs = "0.8"
|