summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorNick Gerace <nickagerace@gmail.com>2020-11-24 23:57:48 -0500
committerNick Gerace <nickagerace@gmail.com>2020-11-25 00:24:36 -0500
commit1462a3d7e1d30db3591061f260d89011d7d1fe13 (patch)
tree2433fe25d261f179c5c75515d16bcfdcbee350a5 /Cargo.toml
parent80144aa53492c856aab0b14f14675bee691a4602 (diff)
downloadgfold-1462a3d7e1d30db3591061f260d89011d7d1fe13.zip
Add unpushed commit detection
Add unpushed commit detection. Add logging stack with envlogger and log crates. Add debug target to Makefile. Update example output in README to include unpushed. Add debug statements for general usage. Update bare repo detection to use upstream functionality.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 19f3fad..b128efe 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,7 +12,9 @@ keywords = ["git", "cli"]
categories = ["command-line-utilities", "command-line-interface"]
[dependencies]
+env_logger = "^0.8"
eyre = "^0.6"
-structopt = "^0.3"
git2 = "^0.13"
+log = "^0.4"
prettytable-rs = "^0.8"
+structopt = "^0.3"