diff options
author | Nick Gerace <nickagerace@gmail.com> | 2020-10-10 22:57:12 -0400 |
---|---|---|
committer | Nick Gerace <nickagerace@gmail.com> | 2020-10-10 23:04:31 -0400 |
commit | 13afbbf10f3b8506b4321d6026cacdea5f775215 (patch) | |
tree | d33e28e06de67981238a8ccab47f795c588e5e8b /Cargo.toml | |
parent | fe195fffdc878a94c62fb97bc64fc5a0b834e697 (diff) | |
download | gfold-13afbbf10f3b8506b4321d6026cacdea5f775215.zip |
Add eyre for simple backtrace reporting
Add eyre for simple backtrace reporting. Since gfold relies on speed and
efficiency, and sports a relatively small codebase, eyre provides a
simple backtrace report when an error is encountered. Specifically, the
filename and line are the most important parts.
Unrelated, add a cargo doc command to the release Make target.
Adjust existing docs comments to match style.
Change some private definitions to be public.
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 1 |
1 files changed, 1 insertions, 0 deletions
@@ -5,6 +5,7 @@ authors = ["Nick Gerace <nickagerace@gmail.com>"] edition = "2018"
[dependencies]
+eyre = "0.6"
structopt = "0.3"
git2 = "0.13"
prettytable-rs = "0.8"
|