From f935a609c53c5c6031e6848db95c7debed127e27 Mon Sep 17 00:00:00 2001
From: Rong-En Fan <rafan@FreeBSD.org>
Date: Mon, 23 Jul 2007 09:36:51 +0000
Subject: - Set --mandir and --infodir in CONFIGURE_ARGS if the configure
 script   supports them.  This is determined by running ``configure --help''
 in   do-configure target and set the shell variable _LATE_CONFIGURE_ARGS  
 which is then passed to CONFIGURE_ARGS. - Remove --mandir and --infodir in
 ports' Makefile where applicable   Few ports use REINPLACE_CMD to achieve the
 same effect, remove them too. - Correct some manual pages location from
 PREFIX/man to MANPREFIX/man - Define INFO_PATH where necessary - Document
 that .info files are installed in a subdirectory relative to  
 PREFIX/INFO_PATH and slightly change add-plist-info to use INFO_PATH and  
 subdirectory detection.

PR:		ports/111470
Approved by:	portmgr
Discussed with:	stas (Mk/*), gerald (info related stuffs)
Tested by:	pointyhat exp run
---
 x11/gdm/Makefile                | 3 +--
 x11/gsynaptics/Makefile         | 2 --
 x11/stalonetray/Makefile        | 3 +--
 x11/xbindkeys/Makefile          | 1 -
 x11/xnee/Makefile               | 2 +-
 x11/xscreensaver-gnome/Makefile | 1 -
 x11/xscreensaver/Makefile       | 2 +-
 x11/zenity/Makefile             | 1 -
 8 files changed, 4 insertions(+), 11 deletions(-)

(limited to 'x11')

diff --git a/x11/gdm/Makefile b/x11/gdm/Makefile
index b89c1ff97ad7..20d088b5401f 100644
--- a/x11/gdm/Makefile
+++ b/x11/gdm/Makefile
@@ -32,8 +32,7 @@ USE_GMAKE=	yes
 USE_GNOME=	gnomehack intlhack gnomehier libgnomeui librsvg2 gnomedocutils \
 		gnomeprefix
 GNU_CONFIGURE=	yes
-CONFIGURE_ARGS=	--mandir=${PREFIX}/man \
-		--with-console-kit=no
+CONFIGURE_ARGS=	--with-console-kit=no
 CONFIGURE_ENV=	CPPFLAGS="-I${LOCALBASE}/include" \
 		LDFLAGS="-L${LOCALBASE}/lib" \
 		GTKDOC="false"
diff --git a/x11/gsynaptics/Makefile b/x11/gsynaptics/Makefile
index ef788af1e779..c184a4af3224 100644
--- a/x11/gsynaptics/Makefile
+++ b/x11/gsynaptics/Makefile
@@ -22,8 +22,6 @@ USE_ICONV=	yes
 USE_GMAKE=	yes
 GNU_CONFIGURE=	yes
 
-CONFIGURE_ARGS=	--mandir=${PREFIX}/man
-
 CONFIGURE_ENV=	CPPFLAGS=-I${LOCALBASE}/include \
 		LDFLAGS=-L${LOCALBASE}/lib
 
diff --git a/x11/stalonetray/Makefile b/x11/stalonetray/Makefile
index 5b3fc974ae77..9c21e24cfebb 100644
--- a/x11/stalonetray/Makefile
+++ b/x11/stalonetray/Makefile
@@ -17,8 +17,7 @@ USE_BZIP2=	yes
 USE_XPM=	yes
 USE_GNOME=	gnometarget
 GNU_CONFIGURE=	yes
-CONFIGURE_ARGS=	--mandir=${MANPREFIX}/man \
-		--disable-native-kde \
+CONFIGURE_ARGS=	--disable-native-kde \
 		--disable-debug
 
 MAN1=		stalonetray.1
diff --git a/x11/xbindkeys/Makefile b/x11/xbindkeys/Makefile
index 5f7597d5bc2e..14e648607e63 100644
--- a/x11/xbindkeys/Makefile
+++ b/x11/xbindkeys/Makefile
@@ -23,7 +23,6 @@ USE_GNOME=	gnometarget
 GNU_CONFIGURE=	yes
 CONFIGURE_ENV=	CPPFLAGS="-I${LOCALBASE}/include" \
 		LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS=	--mandir=${MANPREFIX}/man
 
 MAN1=		xbindkeys.1
 PLIST_FILES=	bin/xbindkeys %%EXAMPLESDIR%%/xbindkeysrc
diff --git a/x11/xnee/Makefile b/x11/xnee/Makefile
index e26130a48ddb..a02fdca6a91f 100644
--- a/x11/xnee/Makefile
+++ b/x11/xnee/Makefile
@@ -22,7 +22,7 @@ USE_XLIB=	yes
 USE_GNOME=	gnomehack gnometarget
 USE_GMAKE=	yes
 GNU_CONFIGURE=	yes
-CONFIGURE_ARGS=	--mandir=${MANPREFIX}/man --enable-cli --disable-doc
+CONFIGURE_ARGS=	--enable-cli --disable-doc
 
 MAN1=		cnee.1
 INFO=		cnee xnee
diff --git a/x11/xscreensaver-gnome/Makefile b/x11/xscreensaver-gnome/Makefile
index ea4ee9766cc9..0182dc861001 100644
--- a/x11/xscreensaver-gnome/Makefile
+++ b/x11/xscreensaver-gnome/Makefile
@@ -31,7 +31,6 @@ CONFIGURE_ARGS=	--with-gl --with-gle --with-xpm --with-xml \
 		--with-hackdir=${PREFIX}/bin/xscreensaver-hacks \
 		--with-configdir=${PREFIX}/share/xscreensaver/config \
 		--with-jpeg=${LOCALBASE} --without-motif \
-		--mandir=${PREFIX}/man \
 		--without-kerberos
 CONFIGURE_ENV=	CPPFLAGS="-I${LOCALBASE}/include" \
 		LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/x11/xscreensaver/Makefile b/x11/xscreensaver/Makefile
index bbaaea940c2a..368b2eab367a 100644
--- a/x11/xscreensaver/Makefile
+++ b/x11/xscreensaver/Makefile
@@ -27,7 +27,7 @@ CONFIGURE_ARGS=	--without-pam --with-gl --with-gle --with-xpm --with-xml \
 		--with-hackdir=${PREFIX}/bin/xscreensaver-hacks/ \
 		--with-configdir=${PREFIX}/share/xscreensaver/config/ \
 		--with-jpeg=${LOCALBASE} --without-gnome --without-kerberos \
-		--without-motif --mandir=${PREFIX}/man
+		--without-motif
 
 OPTIONS=	ALL_FORTUNES "Run fortune with -sa argument" off \
 		SETUID_HACKS "Install sonar hack suid so it can ping" off
diff --git a/x11/zenity/Makefile b/x11/zenity/Makefile
index 68a07cda9583..c8727ca30603 100644
--- a/x11/zenity/Makefile
+++ b/x11/zenity/Makefile
@@ -26,7 +26,6 @@ USE_BZIP2=	yes
 USE_GETTEXT=	yes
 GNU_CONFIGURE=	yes
 INSTALLS_OMF=	yes
-CONFIGURE_ARGS=	--mandir=${PREFIX}/man
 CONFIGURE_ENV=	CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
 		LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
 
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0