From f4392e746b9dd76d8d0c51269cf14ba13a573d05 Mon Sep 17 00:00:00 2001
From: Olivier Duchateau <olivierd@FreeBSD.org>
Date: Sun, 2 Jun 2013 17:41:00 +0000
Subject: Xfce4-embed-plugin is a plugin that enables the embedding of
 arbitrary application window into the Xfce panel. The window is resized into
 the panel space available, and the associated program can be automatically
 launched if it is not open.

WWW: http://goodies.xfce.org/projects/panel-plugins/xfce4-embed-plugin
---
 x11/Makefile                                       |  1 +
 x11/xfce4-embed-plugin/Makefile                    | 38 ++++++++++++++++++++++
 x11/xfce4-embed-plugin/distinfo                    |  2 ++
 x11/xfce4-embed-plugin/files/extra-patch-configure | 11 +++++++
 x11/xfce4-embed-plugin/pkg-descr                   |  6 ++++
 x11/xfce4-embed-plugin/pkg-plist                   | 31 ++++++++++++++++++
 6 files changed, 89 insertions(+)
 create mode 100644 x11/xfce4-embed-plugin/Makefile
 create mode 100644 x11/xfce4-embed-plugin/distinfo
 create mode 100644 x11/xfce4-embed-plugin/files/extra-patch-configure
 create mode 100644 x11/xfce4-embed-plugin/pkg-descr
 create mode 100644 x11/xfce4-embed-plugin/pkg-plist

(limited to 'x11')

diff --git a/x11/Makefile b/x11/Makefile
index f7441d26005b..a2bdfc297a03 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -365,6 +365,7 @@
     SUBDIR += xf86vidmodeproto
     SUBDIR += xfce4-clipman-plugin
     SUBDIR += xfce4-conf
+    SUBDIR += xfce4-embed-plugin
     SUBDIR += xfce4-quicklauncher-plugin
     SUBDIR += xfce4-screenshooter-plugin
     SUBDIR += xfce4-taskmanager
diff --git a/x11/xfce4-embed-plugin/Makefile b/x11/xfce4-embed-plugin/Makefile
new file mode 100644
index 000000000000..2dfd2605dfbf
--- /dev/null
+++ b/x11/xfce4-embed-plugin/Makefile
@@ -0,0 +1,38 @@
+# Created by: Olivier Duchateau
+# $FreeBSD$
+#
+
+PORTNAME=	xfce4-embed-plugin
+PORTVERSION=	1.4.1
+CATEGORIES=	x11 xfce
+MASTER_SITES=	${MASTER_SITE_XFCE}
+MASTER_SITE_SUBDIR=	src/panel-plugins/${PORTNAME}/${PORTVERSION:R}
+DIST_SUBDIR=	xfce4
+
+MAINTAINER=	xfce@FreeBSD.org
+COMMENT=	Embed arbitrary windows into the Xfce panel
+
+USE_BZIP2=	yes
+USE_AUTOTOOLS=	libtool
+GNU_CONFIGURE=	yes
+USE_GMAKE=	yes
+USES=	pkgconfig
+USE_XORG=	x11
+USE_GNOME=	glib20 gtk20 intltool intlhack
+USE_XFCE=	configenv libmenu libutil panel
+
+OPTIONS_DEFINE=	NLS
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USES+=	gettext
+CONFIGURE_ARGS+=--enable-nls
+PLIST_SUB+=	NLS=""
+.else
+EXTRA_PATCHES=	${FILESDIR}/extra-patch-configure
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+=	NLS="@comment "
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11/xfce4-embed-plugin/distinfo b/x11/xfce4-embed-plugin/distinfo
new file mode 100644
index 000000000000..52e70e92049e
--- /dev/null
+++ b/x11/xfce4-embed-plugin/distinfo
@@ -0,0 +1,2 @@
+SHA256 (xfce4/xfce4-embed-plugin-1.4.1.tar.bz2) = b82f6894377fd0ce8273609baf99bd59fa70c2ec70214a54dd58c96dcfa31f68
+SIZE (xfce4/xfce4-embed-plugin-1.4.1.tar.bz2) = 330908
diff --git a/x11/xfce4-embed-plugin/files/extra-patch-configure b/x11/xfce4-embed-plugin/files/extra-patch-configure
new file mode 100644
index 000000000000..af10454e02c8
--- /dev/null
+++ b/x11/xfce4-embed-plugin/files/extra-patch-configure
@@ -0,0 +1,11 @@
+--- ./configure.orig	2013-06-01 18:40:34.000000000 +0000
++++ ./configure	2013-06-02 09:32:46.000000000 +0000
+@@ -13340,7 +13340,7 @@
+ 
+     fi
+   fi
+-     USE_NLS=yes
++#     USE_NLS=yes
+ 
+ 
+     gt_cv_have_gettext=no
diff --git a/x11/xfce4-embed-plugin/pkg-descr b/x11/xfce4-embed-plugin/pkg-descr
new file mode 100644
index 000000000000..e058a494e773
--- /dev/null
+++ b/x11/xfce4-embed-plugin/pkg-descr
@@ -0,0 +1,6 @@
+Xfce4-embed-plugin is a plugin that enables the embedding of arbitrary
+application window into the Xfce panel. The window is resized into the
+panel space available, and the associated program can be automatically
+launched if it is not open.
+
+WWW: http://goodies.xfce.org/projects/panel-plugins/xfce4-embed-plugin
diff --git a/x11/xfce4-embed-plugin/pkg-plist b/x11/xfce4-embed-plugin/pkg-plist
new file mode 100644
index 000000000000..efc5286aab59
--- /dev/null
+++ b/x11/xfce4-embed-plugin/pkg-plist
@@ -0,0 +1,31 @@
+lib/xfce4/panel/plugins/libembed.a
+lib/xfce4/panel/plugins/libembed.la
+lib/xfce4/panel/plugins/libembed.so
+%%NLS%%share/locale/ar/LC_MESSAGES/xfce4-embed-plugin.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/xfce4-embed-plugin.mo
+%%NLS%%share/locale/da/LC_MESSAGES/xfce4-embed-plugin.mo
+%%NLS%%share/locale/de/LC_MESSAGES/xfce4-embed-plugin.mo
+%%NLS%%share/locale/el/LC_MESSAGES/xfce4-embed-plugin.mo
+%%NLS%%share/locale/es/LC_MESSAGES/xfce4-embed-plugin.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/xfce4-embed-plugin.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/xfce4-embed-plugin.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/xfce4-embed-plugin.mo
+%%NLS%%share/locale/id/LC_MESSAGES/xfce4-embed-plugin.mo
+%%NLS%%share/locale/it/LC_MESSAGES/xfce4-embed-plugin.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/xfce4-embed-plugin.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/xfce4-embed-plugin.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/xfce4-embed-plugin.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/xfce4-embed-plugin.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/xfce4-embed-plugin.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/xfce4-embed-plugin.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/xfce4-embed-plugin.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/xfce4-embed-plugin.mo
+%%NLS%%share/locale/sl/LC_MESSAGES/xfce4-embed-plugin.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/xfce4-embed-plugin.mo
+%%NLS%%share/locale/ug/LC_MESSAGES/xfce4-embed-plugin.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/xfce4-embed-plugin.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/xfce4-embed-plugin.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/xfce4-embed-plugin.mo
+share/xfce4/panel/plugins/embed.desktop
+%%NLS%%@dirrmtry share/locale/ug/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ug
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0