From 8d9d366d7002dac75f6c26484bb6a6df84c5ebb1 Mon Sep 17 00:00:00 2001
From: Joe Marcus Clarke <marcus@FreeBSD.org>
Date: Thu, 14 Nov 2002 18:15:25 +0000
Subject: Add startup-notification, a minimal implementation of the startup
 notification spec from freedesktop.org.

---
 x11/Makefile                                   |  1 +
 x11/startup-notification/Makefile              | 33 ++++++++++++++++++++++++++
 x11/startup-notification/distinfo              |  1 +
 x11/startup-notification/files/patch-configure | 10 ++++++++
 x11/startup-notification/pkg-comment           |  1 +
 x11/startup-notification/pkg-descr             |  4 ++++
 x11/startup-notification/pkg-plist             | 12 ++++++++++
 7 files changed, 62 insertions(+)
 create mode 100644 x11/startup-notification/Makefile
 create mode 100644 x11/startup-notification/distinfo
 create mode 100644 x11/startup-notification/files/patch-configure
 create mode 100644 x11/startup-notification/pkg-comment
 create mode 100644 x11/startup-notification/pkg-descr
 create mode 100644 x11/startup-notification/pkg-plist

(limited to 'x11')

diff --git a/x11/Makefile b/x11/Makefile
index ab9a4999423a..6f1176744009 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -94,6 +94,7 @@
     SUBDIR += ruby-panel-applet
     SUBDIR += rxvt
     SUBDIR += rxvt-devel
+    SUBDIR += startup-notification
     SUBDIR += stockticker_applet
     SUBDIR += sxpc
     SUBDIR += temperature.app
diff --git a/x11/startup-notification/Makefile b/x11/startup-notification/Makefile
new file mode 100644
index 000000000000..5bd2dd9bbfd2
--- /dev/null
+++ b/x11/startup-notification/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for:	startup-notification
+# Date created:				14 November 2002
+# Whom:					Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME=	startup-notification
+PORTVERSION=	0.3
+CATEGORIES=	x11 gnome
+MASTER_SITES=	${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR=	sources/${PORTNAME}/0.3
+DIST_SUBDIR=	gnome2
+
+MAINTAINER=	gnome@FreeBSD.org
+
+USE_BZIP2=	yes
+USE_X_PREFIX=	yes
+USE_REINPLACE=	yes
+USE_GMAKE=	yes
+USE_GNOMENG=	yes
+USE_GNOME=	gnomeprefix gnomehack gnomehier
+USE_LIBTOOL=	yes
+INSTALLS_SHLIB=	yes
+CONFIGURE_ENV=	CPPFLAGS="-I${LOCALBASE}/include" \
+		LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET=	--target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+
+post-patch:
+	@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+		 s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/x11/startup-notification/distinfo b/x11/startup-notification/distinfo
new file mode 100644
index 000000000000..72bf6478ed4b
--- /dev/null
+++ b/x11/startup-notification/distinfo
@@ -0,0 +1 @@
+MD5 (gnome2/startup-notification-0.3.tar.bz2) = 450eb7d74343b09d9a7daa9d42ad91d2
diff --git a/x11/startup-notification/files/patch-configure b/x11/startup-notification/files/patch-configure
new file mode 100644
index 000000000000..18ddad392e1e
--- /dev/null
+++ b/x11/startup-notification/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig	Thu Nov 14 13:11:13 2002
++++ configure	Thu Nov 14 13:11:36 2002
+@@ -7203,6 +7203,7 @@
+ 
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+ 
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/x11/startup-notification/pkg-comment b/x11/startup-notification/pkg-comment
new file mode 100644
index 000000000000..a3a4ccee575f
--- /dev/null
+++ b/x11/startup-notification/pkg-comment
@@ -0,0 +1 @@
+Library that supports startup notification spec from freedesktop.org
diff --git a/x11/startup-notification/pkg-descr b/x11/startup-notification/pkg-descr
new file mode 100644
index 000000000000..404543488443
--- /dev/null
+++ b/x11/startup-notification/pkg-descr
@@ -0,0 +1,4 @@
+startup-notification is a minimal library that supports the startup 
+notification spec described at freedesktop.org.
+
+WWW: http://freedesktop.org
diff --git a/x11/startup-notification/pkg-plist b/x11/startup-notification/pkg-plist
new file mode 100644
index 000000000000..1bf261d52b32
--- /dev/null
+++ b/x11/startup-notification/pkg-plist
@@ -0,0 +1,12 @@
+include/startup-notification-1.0/libsn/sn-common.h
+include/startup-notification-1.0/libsn/sn-launchee.h
+include/startup-notification-1.0/libsn/sn-launcher.h
+include/startup-notification-1.0/libsn/sn-monitor.h
+include/startup-notification-1.0/libsn/sn-util.h
+include/startup-notification-1.0/libsn/sn.h
+lib/libstartup-notification-1.a
+lib/libstartup-notification-1.so
+lib/libstartup-notification-1.so.0
+libdata/pkgconfig/libstartup-notification-1.0.pc
+@dirrm include/startup-notification-1.0/libsn
+@dirrm include/startup-notification-1.0
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0