From 74ce78f457a073e972a4d5ab65d6d55ddf1d16e7 Mon Sep 17 00:00:00 2001
From: William Grzybowski <wg@FreeBSD.org>
Date: Thu, 20 Jun 2013 22:54:24 +0000
Subject: x11/lxpanel: minor fixes

- Add LICENSE (GPLv2 MIT)
- Add DOCS option
- Fix NLS option

PR:		ports/179712
Submitted by:	nemysis <nemysis@gmx.ch>
---
 x11/lxpanel/Makefile  |  25 +++++--
 x11/lxpanel/pkg-plist | 176 ++++++++++++++++++++++----------------------------
 2 files changed, 99 insertions(+), 102 deletions(-)

(limited to 'x11')

diff --git a/x11/lxpanel/Makefile b/x11/lxpanel/Makefile
index 0e8e660d4ce3..6015bf095d89 100644
--- a/x11/lxpanel/Makefile
+++ b/x11/lxpanel/Makefile
@@ -5,15 +5,18 @@ PORTNAME=	lxpanel
 PORTVERSION=	0.5.12
 PORTREVISION=	1
 CATEGORIES=	x11
-MASTER_SITES=	SF/lxde/LXPanel%20%28desktop%20panel%29/LXPanel%20${PORTVERSION}
+MASTER_SITES=	SF/lxde/LXPanel%20%28desktop%20panel%29/LXPanel%20${PORTVERSION}/
 
 MAINTAINER=	wg@FreeBSD.org
 COMMENT=	Lightweight X11 desktop panel
 
+LICENSE=	GPLv2 MIT
+LICENSE_COMB=	dual
+
 LIB_DEPENDS=	menu-cache:${PORTSDIR}/x11/menu-cache
 RUN_DEPENDS=	${LOCALBASE}/share/desktop-directories/lxde-audio-video.directory:${PORTSDIR}/x11/lxmenu-data
 
-OPTIONS_DEFINE=	ALSA NLS
+OPTIONS_DEFINE=	DOCS ALSA NLS
 OPTIONS_DEFAULT=NLS
 
 USE_XORG=	x11 xmu
@@ -22,7 +25,7 @@ USES=		pathfix pkgconfig
 GNU_CONFIGURE=	yes
 USE_AUTOTOOLS=	automake:env
 CONFIGURE_ARGS=	--prefix=${PREFIX} \
-		--with-plugins=volume,deskno,kbled,xkb,batt\
+		--with-plugins=volume,deskno,kbled,xkb,batt \
 		CPPFLAGS="-I${LOCALBASE}/include" \
 		LDFLAGS="-L${LOCALBASE}/lib"
 CFLAGS+=	-I${WRKSRC} -Wno-return-type
@@ -31,6 +34,8 @@ USE_GMAKE=	yes
 
 MAN1=		lxpanel.1 lxpanelctl.1
 
+PORTDOCS=	AUTHORS README TODO
+
 .include <bsd.port.options.mk>
 
 .if ${PORT_OPTIONS:MALSA}
@@ -43,14 +48,24 @@ CONFIGURE_ARGS+=--disable-alsa
 USES+=		gettext
 PLIST_SUB+=	NLS=""
 .else
-CONFIGURE_ARGS+=--disable-nls
 PLIST_SUB+=	NLS="@comment "
 .endif
 
-pre-patch:
+post-patch:
 	@${REINPLACE_CMD} -e 's,linux,sys,' \
 		${WRKSRC}/src/plugins/volume/volume-impl.c
 	@${REINPLACE_CMD} -e 's,$$(DATADIRNAME)/locale,share/locale,' \
 		${WRKSRC}/po/Makefile.in.in
 
+.if ! ${PORT_OPTIONS:MNLS}
+	@${REINPLACE_CMD} -e 's,po man,man,' \
+		${WRKSRC}/Makefile.in
+.endif
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+	@${MKDIR} ${DOCSDIR}
+	${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
 .include <bsd.port.mk>
diff --git a/x11/lxpanel/pkg-plist b/x11/lxpanel/pkg-plist
index 68131b07795d..676bb07e71bc 100644
--- a/x11/lxpanel/pkg-plist
+++ b/x11/lxpanel/pkg-plist
@@ -1,12 +1,73 @@
 bin/lxpanel
 bin/lxpanelctl
+include/lxpanel/plugin.h
 lib/lxpanel/plugins/batt.so
 lib/lxpanel/plugins/deskno.so
 lib/lxpanel/plugins/kbled.so
 lib/lxpanel/plugins/volume.so
 lib/lxpanel/plugins/xkb.so
 libdata/pkgconfig/lxpanel.pc
-include/lxpanel/plugin.h
+%%NLS%%share/locale/af/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/ar/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/be/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/bg/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/bn/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/bn_IN/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/da/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/de/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/el/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/en_GB/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/es/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/es_VE/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/et/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/eu/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/fa/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/fo/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/frp/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/he/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/hr/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/id/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/it/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/kk/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/km/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/lg/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/ml/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/ms/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/nn/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/pa/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/ps/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/sl/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/sr@latin/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/te/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/th/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/tt_RU/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/ug/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/ur/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/ur_PK/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/lxpanel.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/lxpanel.mo
 %%DATADIR%%/images/background.png
 %%DATADIR%%/images/capslock-off.png
 %%DATADIR%%/images/capslock-on.png
@@ -172,105 +233,26 @@ include/lxpanel/plugin.h
 %%DATADIR%%/xkeyboardconfig/layouts.cfg
 %%DATADIR%%/xkeyboardconfig/models.cfg
 %%DATADIR%%/xkeyboardconfig/toggle.cfg
-%%NLS%%share/locale/af/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/ar/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/be/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/bg/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/bn/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/bn_IN/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/ca/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/cs/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/da/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/de/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/el/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/en_GB/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/es/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/es_VE/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/et/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/eu/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/fa/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/fi/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/fo/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/fr/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/frp/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/gl/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/he/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/hr/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/hu/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/id/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/it/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/ja/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/kk/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/km/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/ko/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/lg/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/lt/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/ml/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/ms/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/nb/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/nl/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/nn/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/pa/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/pl/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/ps/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/pt/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/pt_BR/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/ro/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/ru/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/sk/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/sl/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/sr/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/sr@latin/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/sv/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/te/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/th/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/tr/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/tt_RU/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/ug/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/uk/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/ur/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/ur_PK/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/vi/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/zh_CN/LC_MESSAGES/lxpanel.mo
-%%NLS%%share/locale/zh_TW/LC_MESSAGES/lxpanel.mo
-@dirrm %%DATADIR%%/images/xkb-flags
-@dirrm %%DATADIR%%/images
-@dirrm %%DATADIR%%/profile/default/panels
-@dirrm %%DATADIR%%/profile/default
+@dirrm %%DATADIR%%/xkeyboardconfig
+@dirrm %%DATADIR%%/ui
 @dirrm %%DATADIR%%/profile/two_panels/panels
 @dirrm %%DATADIR%%/profile/two_panels
+@dirrm %%DATADIR%%/profile/default/panels
+@dirrm %%DATADIR%%/profile/default
 @dirrm %%DATADIR%%/profile
-@dirrm %%DATADIR%%/ui
-@dirrm %%DATADIR%%/xkeyboardconfig
+@dirrm %%DATADIR%%/images/xkb-flags
+@dirrm %%DATADIR%%/images
 @dirrm %%DATADIR%%
-@dirrm include/lxpanel
-@dirrmtry share/locale/bn_IN/LC_MESSAGES
-@dirrmtry share/locale/bn_IN
-@dirrmtry share/locale/es_VE/LC_MESSAGES
-@dirrmtry share/locale/es_VE
-@dirrmtry share/locale/fo/LC_MESSAGES
-@dirrmtry share/locale/fo
-@dirrmtry share/locale/frp/LC_MESSAGES
-@dirrmtry share/locale/frp
-@dirrmtry share/locale/kk/LC_MESSAGES
-@dirrmtry share/locale/kk
-@dirrmtry share/locale/km/LC_MESSAGES
-@dirrmtry share/locale/km
-@dirrmtry share/locale/lg/LC_MESSAGES
-@dirrmtry share/locale/lg
-@dirrmtry share/locale/ps/LC_MESSAGES
-@dirrmtry share/locale/ps
-@dirrmtry share/locale/sr@latin/LC_MESSAGES
-@dirrmtry share/locale/sr@latin
-@dirrmtry share/locale/te/LC_MESSAGES
-@dirrmtry share/locale/te
-@dirrmtry share/locale/tt_RU/LC_MESSAGES
-@dirrmtry share/locale/tt_RU
-@dirrmtry share/locale/ug/LC_MESSAGES
-@dirrmtry share/locale/ug
-@dirrmtry share/locale/ur/LC_MESSAGES
-@dirrmtry share/locale/ur
-@dirrmtry share/locale/ur_PK/LC_MESSAGES
-@dirrmtry share/locale/ur_PK
+%%NLS%%@dirrmtry share/locale/ur_PK/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ur_PK
+%%NLS%%@dirrmtry share/locale/tt_RU/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/tt_RU
+%%NLS%%@dirrmtry share/locale/lg/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/lg
+%%NLS%%@dirrmtry share/locale/frp/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/frp
+%%NLS%%@dirrmtry share/locale/es_VE/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/es_VE
 @dirrmtry lib/lxpanel/plugins
 @dirrmtry lib/lxpanel
+@dirrmtry include/lxpanel
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0