From 5d9a049b9cd7ec47df1d3dd75d753e71753eb4cb Mon Sep 17 00:00:00 2001
From: Baptiste Daroussin <bapt@FreeBSD.org>
Date: Fri, 14 Jun 2013 12:49:56 +0000
Subject: Use the new USES=display:build While here fix build with recent clang

---
 x11/xgrab/Makefile | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)

(limited to 'x11')

diff --git a/x11/xgrab/Makefile b/x11/xgrab/Makefile
index 862ad2fc99f7..ca0a5773da1a 100644
--- a/x11/xgrab/Makefile
+++ b/x11/xgrab/Makefile
@@ -15,9 +15,9 @@ COMMENT=	X11 image grabber
 
 BUILD_DEPENDS=	xrdb:${PORTSDIR}/x11/xrdb
 
+USES=		display:build
 USE_XORG=	x11
 USE_IMAKE=	yes
-USE_DISPLAY=	yes
 
 MAKE_FLAGS=	BINDIR=${PREFIX}/bin MANDIR=${PREFIX}/man/man1 \
 		XAPPLOADDIR=${PREFIX}/lib/X11/app-defaults  -f
@@ -25,10 +25,9 @@ MAKE_FLAGS=	BINDIR=${PREFIX}/bin MANDIR=${PREFIX}/man/man1 \
 XMKMF=		xmkmf
 CFLAGS+=	-Wno-error=return-type
 
-.if (!defined(DISPLAY) || ${DISPLAY} == "") && !defined(PACKAGE_BUILDING)
-IGNORE=		Requires an active X session (and DISPLAY variable) to run xrdb.  Please compile this while running X.
-.endif
-
 MAN1=		xgrab.1 xgrabsc.1
 
+post-patch:
+	@${REINPLACE_CMD} 's,\*envp,\*\*envp,g' ${WRKSRC}/xgrabxaw.c
+
 .include <bsd.port.mk>
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0