From 98321151979466dbc086163c2a0e662d455f9c86 Mon Sep 17 00:00:00 2001
From: Olivier Duchateau <olivierd@FreeBSD.org>
Date: Wed, 15 Feb 2017 15:56:06 +0000
Subject: - Update to 1.6.11 - Adjust dependencies (reported by QA script) -
 Remove unneeded patches

---
 x11-fm/thunar/Makefile                             | 16 ++++---
 x11-fm/thunar/distinfo                             |  5 ++-
 .../patch-Thunar-folder-handler.desktop.in.in      | 12 ------
 x11-fm/thunar/files/patch-thunar_thunar-file.c     | 30 -------------
 x11-fm/thunar/files/patch-thunar_thunar-folder.c   | 49 ----------------------
 x11-fm/thunar/pkg-plist                            |  1 +
 6 files changed, 11 insertions(+), 102 deletions(-)
 delete mode 100644 x11-fm/thunar/files/patch-Thunar-folder-handler.desktop.in.in
 delete mode 100644 x11-fm/thunar/files/patch-thunar_thunar-file.c
 delete mode 100644 x11-fm/thunar/files/patch-thunar_thunar-folder.c

(limited to 'x11-fm')

diff --git a/x11-fm/thunar/Makefile b/x11-fm/thunar/Makefile
index 50ec82184f74..86fd325f2ec1 100644
--- a/x11-fm/thunar/Makefile
+++ b/x11-fm/thunar/Makefile
@@ -2,8 +2,7 @@
 # $FreeBSD$
 
 PORTNAME=	Thunar
-PORTVERSION=	1.6.10
-PORTREVISION=	2
+PORTVERSION=	1.6.11
 CATEGORIES=	x11-fm xfce
 MASTER_SITES=	XFCE/src/xfce/${PORTNAME:tl}/${PORTVERSION:R}
 DIST_SUBDIR=	xfce4
@@ -16,15 +15,18 @@ LICENSE_COMB=	multi
 LICENSE_FILE=	${WRKSRC}/COPYING ${WRKSRC}/COPYING.LIB
 
 LIB_DEPENDS=	libtumbler-1.so:deskutils/xfce4-tumbler \
-	libdbus-glib-1.so:devel/dbus-glib
+	libdbus-1.so:devel/dbus \
+	libdbus-glib-1.so:devel/dbus-glib \
+	libfontconfig.so:x11-fonts/fontconfig \
+	libfreetype.so:print/freetype2
 RUN_DEPENDS=	pkexec:sysutils/polkit
 
 GNU_CONFIGURE=	yes
 INSTALLS_ICONS=	yes
-USE_GNOME=	gtk20 intltool intlhack gdkpixbuf2
+USE_GNOME=	glib20 gtk20 intltool cairo gdkpixbuf2
 USE_LDCONFIG=	yes
 USE_XFCE=	libexo
-USE_XORG=	sm x11
+USE_XORG=	ice sm x11
 USES=		desktop-file-utils gmake pathfix perl5 libtool pkgconfig \
 	gettext-tools xfce tar:bzip2
 INSTALL_TARGET=	install-strip
@@ -63,9 +65,5 @@ CONFIGURE_ARGS+=--enable-gio-unix \
 post-patch:
 	${REINPLACE_CMD} -e 's|internet-mail|mail-send|' \
 		${WRKSRC}/plugins/thunar-sendto-email/thunar-sendto-email.desktop.in.in
-# Workaround for missing 'inode/directory' content-type icon.
-# https://bugs.freedesktop.org/show_bug.cgi?id=89150
-	${FIND} ${WRKSRC} -type f -name '*.c' \
-		| ${XARGS} ${REINPLACE_CMD} -e 's|inode/directory|folder|'
 
 .include <bsd.port.mk>
diff --git a/x11-fm/thunar/distinfo b/x11-fm/thunar/distinfo
index 0be3491d6999..9ef671d1b930 100644
--- a/x11-fm/thunar/distinfo
+++ b/x11-fm/thunar/distinfo
@@ -1,2 +1,3 @@
-SHA256 (xfce4/Thunar-1.6.10.tar.bz2) = 7e9d24067268900e5e44d3325e60a1a2b2f8f556ec238ec12574fbea15fdee8a
-SIZE (xfce4/Thunar-1.6.10.tar.bz2) = 1948762
+TIMESTAMP = 1487135952
+SHA256 (xfce4/Thunar-1.6.11.tar.bz2) = b1c7c3121827f59610900ef1cc19aa10a50ab2cc3ae38eee15181b64256e8b42
+SIZE (xfce4/Thunar-1.6.11.tar.bz2) = 1929426
diff --git a/x11-fm/thunar/files/patch-Thunar-folder-handler.desktop.in.in b/x11-fm/thunar/files/patch-Thunar-folder-handler.desktop.in.in
deleted file mode 100644
index dc91047ad7ec..000000000000
--- a/x11-fm/thunar/files/patch-Thunar-folder-handler.desktop.in.in
+++ /dev/null
@@ -1,12 +0,0 @@
-Workaround for https://bugs.freedesktop.org/show_bug.cgi?id=89150
-
---- Thunar-folder-handler.desktop.in.in.orig	2013-07-30 05:44:48 UTC
-+++ Thunar-folder-handler.desktop.in.in
-@@ -10,6 +10,6 @@ Terminal=false
- StartupNotify=true
- Type=Application
- Categories=System;Utility;Core;GTK;FileTools;FileManager;
--MimeType=inode/directory;
-+MimeType=inode/directory;folder;
- 
- # vi:set encoding=UTF-8:
diff --git a/x11-fm/thunar/files/patch-thunar_thunar-file.c b/x11-fm/thunar/files/patch-thunar_thunar-file.c
deleted file mode 100644
index bc73151de506..000000000000
--- a/x11-fm/thunar/files/patch-thunar_thunar-file.c
+++ /dev/null
@@ -1,30 +0,0 @@
---- thunar/thunar-file.c.orig	2015-05-22 13:25:36 UTC
-+++ thunar/thunar-file.c
-@@ -795,13 +795,15 @@ thunar_file_monitor (GFileMonitor     *m
-       if (event_type == G_FILE_MONITOR_EVENT_MOVED)
-         {
-           /* reload the target file if cached */
-+          if (other_path == NULL)
-+            return;
-           other_file = thunar_file_cache_lookup (other_path);
-           if (other_file)
-               thunar_file_reload (other_file);
-           else
-               other_file = thunar_file_get (other_path, NULL);
- 
--          if (!other_file)
-+          if (other_file == NULL)
-               return;
- 
-           /* notify the thumbnail cache that we can now also move the thumbnail */
-@@ -3918,7 +3920,9 @@ thunar_file_unwatch (ThunarFile *file)
- gboolean
- thunar_file_reload (ThunarFile *file)
- {
--  _thunar_return_if_fail (THUNAR_IS_FILE (file));
-+  /* if the file has already been destroyed, break here */
-+  if (!THUNAR_IS_FILE (file))
-+      return FALSE;
- 
-   /* clear file pxmap cache */
-   thunar_icon_factory_clear_pixmap_cache (file);
diff --git a/x11-fm/thunar/files/patch-thunar_thunar-folder.c b/x11-fm/thunar/files/patch-thunar_thunar-folder.c
deleted file mode 100644
index 8abd0a99b943..000000000000
--- a/x11-fm/thunar/files/patch-thunar_thunar-folder.c
+++ /dev/null
@@ -1,49 +0,0 @@
---- thunar/thunar-folder.c.orig	2015-05-22 13:25:36 UTC
-+++ thunar/thunar-folder.c
-@@ -773,27 +773,30 @@ thunar_folder_monitor (GFileMonitor     
-             {
-               /* destroy the old file and update the new one */
-               thunar_file_destroy (lp->data);
--              file = thunar_file_get(other_file, NULL);
--              if (file != NULL && THUNAR_IS_FILE (file))
-+              if (other_file != NULL)
-                 {
--                  thunar_file_reload (file);
--
--                  /* if source and target folders are different, also tell
--                     the target folder to reload for the changes */
--                  if (thunar_file_has_parent (file))
-+                  file = thunar_file_get(other_file, NULL);
-+                  if (file != NULL && THUNAR_IS_FILE (file))
-                     {
--                      other_parent = thunar_file_get_parent (file, NULL);
--                      if (other_parent &&
--                          !g_file_equal (thunar_file_get_file(folder->corresponding_file),
--                                         thunar_file_get_file(other_parent)))
-+                      thunar_file_reload (file);
-+
-+                      /* if source and target folders are different, also tell
-+                         the target folder to reload for the changes */
-+                      if (thunar_file_has_parent (file))
-                         {
--                          thunar_file_reload (other_parent);
--                          g_object_unref (other_parent);
-+                          other_parent = thunar_file_get_parent (file, NULL);
-+                          if (other_parent &&
-+                              !g_file_equal (thunar_file_get_file(folder->corresponding_file),
-+                                             thunar_file_get_file(other_parent)))
-+                            {
-+                              thunar_file_reload (other_parent);
-+                              g_object_unref (other_parent);
-+                            }
-                         }
--                    }
- 
--                  /* drop reference on the other file */
--                  g_object_unref (file);
-+                      /* drop reference on the other file */
-+                      g_object_unref (file);
-+                    }
-                 }
- 
-               /* reload the folder of the source file */
diff --git a/x11-fm/thunar/pkg-plist b/x11-fm/thunar/pkg-plist
index f61a28bf1241..b2fc3a739e82 100644
--- a/x11-fm/thunar/pkg-plist
+++ b/x11-fm/thunar/pkg-plist
@@ -62,6 +62,7 @@ share/icons/hicolor/scalable/apps/Thunar.svg
 %%NLS%%share/locale/es/LC_MESSAGES/Thunar.mo
 %%NLS%%share/locale/et/LC_MESSAGES/Thunar.mo
 %%NLS%%share/locale/eu/LC_MESSAGES/Thunar.mo
+%%NLS%%share/locale/fa_IR/LC_MESSAGES/Thunar.mo
 %%NLS%%share/locale/fi/LC_MESSAGES/Thunar.mo
 %%NLS%%share/locale/fr/LC_MESSAGES/Thunar.mo
 %%NLS%%share/locale/gl/LC_MESSAGES/Thunar.mo
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0