From 830b8073e53f8d98c4b26e996836dc9d0b194f5c Mon Sep 17 00:00:00 2001
From: John Marino <marino@FreeBSD.org>
Date: Fri, 30 May 2014 08:50:20 +0000
Subject: www/firefox(seamonkey)-i18n: explicitly use UNZIP_CMD

The extraction of xpi requires zip (infozip to be precise).  Rather than
use variables EXTRACT_CMD and EXTRACT_BEFORE_ARGS, use UNZIP_CMD and
the default "-qo" arguments to future-proof these ports (depending on the
implemention, the original variables may default to tar arguments if they
are defined at all).  Covered by general infrastructure blanket.
---
 www/firefox-i18n/Makefile   | 2 +-
 www/seamonkey-i18n/Makefile | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

(limited to 'www')

diff --git a/www/firefox-i18n/Makefile b/www/firefox-i18n/Makefile
index f780a5295973..c1287e5047ae 100644
--- a/www/firefox-i18n/Makefile
+++ b/www/firefox-i18n/Makefile
@@ -51,7 +51,7 @@ pre-everything::
 do-extract:
 	@${MKDIR} ${WRKSRC}
 	@for lang in ${FIREFOX_I18N_}; do \
-		if ! (${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/$$lang.xpi -d ${WRKSRC}/langpack-$$lang@firefox.mozilla.org);\
+		if ! (${UNZIP_CMD} -qo ${_DISTDIR}/$$lang.xpi -d ${WRKSRC}/langpack-$$lang@firefox.mozilla.org);\
 		then \
 			exit 1; \
 		fi; \
diff --git a/www/seamonkey-i18n/Makefile b/www/seamonkey-i18n/Makefile
index c71d8c714d07..d3597f260c06 100644
--- a/www/seamonkey-i18n/Makefile
+++ b/www/seamonkey-i18n/Makefile
@@ -51,7 +51,7 @@ pre-everything::
 do-extract:
 	@${MKDIR} ${WRKSRC}
 	@for lang in ${SEAMONKEY_I18N_}; do \
-		if ! (${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${_DISTDIR}/seamonkey-${PORTVERSION}.$$lang.langpack.xpi -d ${WRKSRC}/langpack-$$lang@seamonkey.mozilla.org);\
+		if ! (${UNZIP_CMD} -qo ${_DISTDIR}/seamonkey-${PORTVERSION}.$$lang.langpack.xpi -d ${WRKSRC}/langpack-$$lang@seamonkey.mozilla.org);\
 		then \
 			exit 1; \
 		fi; \
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0