From 0de24ae133b3576a39fb548cb9492bb4f1dcdd01 Mon Sep 17 00:00:00 2001
From: Clement Laforet <clement@FreeBSD.org>
Date: Wed, 7 Jan 2004 00:44:11 +0000
Subject: Add mod_cvs-0.5.91 (known as mod_cvs2), apache2 version of mod_cvs.

mod_cvs recognizes if the files in your webtree are checked out
from a CVS repository. If so, it checks if the file is up-to-date
and, if not, updates it.
Another neat feature of mod_cvs is the date-checkout feature. You
can specify a date in the URI that gets passed to CVS, which checks
out an older revision of the requested file and sends it to the
user.

WWW: http://resare.com/noa/mod_cvs/

Approved by:    erwin (mentor) (implicitly)
---
 www/mod_cvs2/Makefile    | 36 ++++++++++++++++++++++++++++++++++++
 www/mod_cvs2/distinfo    |  1 +
 www/mod_cvs2/pkg-descr   | 10 ++++++++++
 www/mod_cvs2/pkg-message |  6 ++++++
 www/mod_cvs2/pkg-plist   |  4 ++++
 5 files changed, 57 insertions(+)
 create mode 100644 www/mod_cvs2/Makefile
 create mode 100644 www/mod_cvs2/distinfo
 create mode 100644 www/mod_cvs2/pkg-descr
 create mode 100644 www/mod_cvs2/pkg-message
 create mode 100644 www/mod_cvs2/pkg-plist

(limited to 'www/mod_cvs2')

diff --git a/www/mod_cvs2/Makefile b/www/mod_cvs2/Makefile
new file mode 100644
index 000000000000..8a0f57f46714
--- /dev/null
+++ b/www/mod_cvs2/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for:	mod_cvs2
+# Date created:				6 January 2003
+# Whom:					Clement Laforet <clement@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME=	mod_cvs
+PORTVERSION=	0.5.91
+CATEGORIES=	www
+MASTER_SITES=	http://resare.com/noa/mod_cvs/dist/
+
+MAINTAINER=	clement@FreeBSD.org
+COMMENT=	A module that makes Apache 2 CVS aware
+
+USE_APACHE=	yes
+WITH_APACHE2=	yes
+
+LATEST_LINK=	mod_cvs2
+
+PORTDOCS=	reference.html guide.html README
+
+do-build:
+	@(cd ${WRKSRC} && ${APXS} -c ${PORTNAME}.c)
+
+do-install:
+	@(cd ${WRKSRC} && ${APXS} -i -A -n ${PORTNAME:S/mod_//} ${PORTNAME}.la)
+.if !defined (NOPORTDOCS)
+	@${MKDIR} ${DOCSDIR}
+	@${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.   for f in ${PORTDOCS:NREADME}
+	@${INSTALL_DATA} ${WRKSRC}/doc/${f} ${DOCSDIR}
+.   endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/mod_cvs2/distinfo b/www/mod_cvs2/distinfo
new file mode 100644
index 000000000000..de3d66d8b5cc
--- /dev/null
+++ b/www/mod_cvs2/distinfo
@@ -0,0 +1 @@
+MD5 (mod_cvs-0.5.91.tar.gz) = ef100c30ff734464c6194a2e707136b5
diff --git a/www/mod_cvs2/pkg-descr b/www/mod_cvs2/pkg-descr
new file mode 100644
index 000000000000..d0b9f664b229
--- /dev/null
+++ b/www/mod_cvs2/pkg-descr
@@ -0,0 +1,10 @@
+mod_cvs recognizes if the files in your webtree are checked out
+from a CVS repository. If so, it checks if the file is up-to-date
+and, if not, updates it.
+
+Another neat feature of mod_cvs is the date-checkout feature. You
+can specify a date in the URI that gets passed to CVS, which checks
+out an older revision of the requested file and sends it to the
+user.
+
+WWW: http://resare.com/noa/mod_cvs/
diff --git a/www/mod_cvs2/pkg-message b/www/mod_cvs2/pkg-message
new file mode 100644
index 000000000000..980fb7be273b
--- /dev/null
+++ b/www/mod_cvs2/pkg-message
@@ -0,0 +1,6 @@
+-----------------------------------------------------------------
+You have installed mod_cvs, a module that makes Apache CVS aware.
+
+For help on using this module, please see the mod_cvs reference:
+    http://www.sub.nu/mod_cvs/reference.shtml
+-----------------------------------------------------------------
diff --git a/www/mod_cvs2/pkg-plist b/www/mod_cvs2/pkg-plist
new file mode 100644
index 000000000000..cb494f3c1163
--- /dev/null
+++ b/www/mod_cvs2/pkg-plist
@@ -0,0 +1,4 @@
+libexec/apache2/mod_cvs.so
+@exec %D/sbin/apxs -e -a -n cvs %D/%f
+@unexec %D/sbin/apxs -e -a -n cvs %D/%f
+@unexec echo "===>  If you do not plan on reinstalling mod_cvs, you must manually remove"; echo "===>  references to it in httpd.conf."
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0