From ff80a7bc86044b599c2fbbc2ef526a55b323c06a Mon Sep 17 00:00:00 2001
From: Kris Kennaway <kris@FreeBSD.org>
Date: Mon, 21 Feb 2000 09:19:19 +0000
Subject: Clean up the makefile a bit (PR) and add a bunch of new MASTER_SITEs

PR:	15970
Submitted by:	tkato@prontomail.ne.jp
---
 security/rsaref/Makefile       | 42 ++++++++++++++++++++++++------------------
 security/rsaref/files/Makefile | 13 +++++--------
 security/rsaref/pkg-plist      | 14 +++++++-------
 3 files changed, 36 insertions(+), 33 deletions(-)

(limited to 'security')

diff --git a/security/rsaref/Makefile b/security/rsaref/Makefile
index 5e0336a5fd7c..5dfe34c7d446 100644
--- a/security/rsaref/Makefile
+++ b/security/rsaref/Makefile
@@ -1,25 +1,28 @@
-# New ports collection makefile for: rsaref
-# Version required:     2.0
-#
-# Date created:         2 Feb 1997
-# Whom:                 ache
+# New ports collection makefile for:	rsaref
+# Version required:	2.0
+# Date created:		2 Feb 1997
+# Whom:			ache
 #
 # $FreeBSD$
 #
 
-DISTNAME=       rsaref20.1996
-PKGNAME=        rsaref-2.0
-CATEGORIES=     security
-MASTER_SITES=   ftp://utopia.hacktic.nl/pub/replay/pub/crypto/LIBS/rsa/ \
-		ftp://ftp.replay.com/pub/crypto/crypto/LIBS/rsa \
-		ftp://ftp.tuwien.ac.at/opsys/linux/replay.com/crypto/LIBS/math/ \
-		ftp://ftp.zedz.net/pub/crypto/crypto/LIBS/rsa/
-EXTRACT_SUFX=   .tar.Z
+DISTNAME=	rsaref20.1996
+PKGNAME=	rsaref-2.0
+CATEGORIES=	security
+MASTER_SITES=	ftp://ftp.deva.net/pub/sources/crypto/ \
+		ftp://ftp.kddlabs.co.jp/.7/inet/caida/bmwt/ \
+		ftp://ftp.zedz.net/pub/crypto/crypto/LIBS/rsa/ \
+		ftp://ftp.hacktic.nl/pub/crypto/crypto/LIBS/rsa/ \
+		ftp://ftp.demon.net/pub/mirrors/crypto/replay/crypto/LIBS/rsa/ \
+		ftp://ftp.jyu.fi/.3/ftp.zedz.net/pub/replay/crypto/LIBS/rsa/ \
+		ftp://ftp.funet.fi/pub/mirrors/utopia.hacktic.nl/crypto/LIBS/rsa/ \
+		ftp://ftp.fu-berlin.de/unix/security/replay-mirror/crypto/LIBS/rsa/
+EXTRACT_SUFX=	.tar.Z
 
 MAINTAINER=	kris@FreeBSD.ORG
 
-WRKSRC=         ${WRKDIR}/source
-RESTRICTED=     "Crypto"
+WRKSRC=		${WRKDIR}/source
+RESTRICTED=	"Crypto"
 
 pre-configure:
 	${CP} ${FILESDIR}/Makefile ${WRKSRC}
@@ -30,8 +33,11 @@ pre-configure:
 
 post-install:
 	${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
-	${INSTALL} -d -m 555 ${PREFIX}/share/doc/rsaref
-	cd ${WRKDIR}/doc && ${INSTALL_DATA} info.txt rsaref.txt \
-		${PREFIX}/share/doc/rsaref
+.if !defined(NOPORTDOCS)
+	@${MKDIR} ${PREFIX}/share/doc/rsaref
+.for file in info.txt rsaref.txt
+	${INSTALL_DATA} ${WRKSRC}/../doc/${file} ${PREFIX}/share/doc/rsaref
+.endfor
+.endif
 
 .include <bsd.port.mk>
diff --git a/security/rsaref/files/Makefile b/security/rsaref/files/Makefile
index 0b6116b791a3..6ea73883d563 100644
--- a/security/rsaref/files/Makefile
+++ b/security/rsaref/files/Makefile
@@ -1,3 +1,5 @@
+# $FreeBSD$
+
 O= o
 SO= so
 LIB= ar
@@ -32,11 +34,6 @@ $(SORSAREFLIB) : desc.$(SO) digit.$(SO) md2c.$(SO) md5c.$(SO) nn.$(SO) prime.$(S
 .endif
 
 install:
-	install -c -m 444 -o bin -g bin rsa.h _des.h _md2.h _md5.h rsaref.h global.h ${PREFIX}/include
-.if ${PORTOBJFORMAT} == elf
-	install -c -m 644 -o bin -g bin librsaref.a librsaref.so.2 ${PREFIX}/lib
-	(cd ${PREFIX}/lib; ln -sf librsaref.so.2 librsaref.so)
-.else
-	install -c -m 644 -o bin -g bin librsaref.a librsaref.so.2.0 ${PREFIX}/lib
-	(cd ${PREFIX}/lib; ln -sf librsaref.so.2.0 librsaref.so)
-.endif
+	${INSTALL_DATA} rsa.h _des.h _md2.h _md5.h rsaref.h global.h ${PREFIX}/include
+	${INSTALL_DATA} ${RSAREFLIB} ${SORSAREFLIB} ${PREFIX}/lib
+	ln -sf ${SORSAREFLIB} ${PREFIX}/lib/librsaref.so
diff --git a/security/rsaref/pkg-plist b/security/rsaref/pkg-plist
index 2cd9321a0528..f8684dfc7cd3 100644
--- a/security/rsaref/pkg-plist
+++ b/security/rsaref/pkg-plist
@@ -1,14 +1,14 @@
-lib/librsaref.a
-lib/librsaref.so.2
-lib/librsaref.so
-@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
-@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
-include/rsa.h
+include/_des.h
 include/_md2.h
 include/_md5.h
-include/_des.h
 include/global.h
+include/rsa.h
 include/rsaref.h
+lib/librsaref.a
+lib/librsaref.so
+lib/librsaref.so.2
+@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
+@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R
 share/doc/rsaref/info.txt
 share/doc/rsaref/rsaref.txt
 @dirrm share/doc/rsaref
-- 
cgit v1.2.3