From 6f5d9a41a4255eca274b6923ab3d34c10165d615 Mon Sep 17 00:00:00 2001
From: "David E. O'Brien" <obrien@FreeBSD.org>
Date: Thu, 24 Dec 1998 17:52:35 +0000
Subject: Attempt to not "exit 1" if the distfile is missing.  Otherwise batch
 fetching of distfiles is harder than I would like.

---
 security/bro/Makefile | 17 +++++------------
 1 file changed, 5 insertions(+), 12 deletions(-)

(limited to 'security')

diff --git a/security/bro/Makefile b/security/bro/Makefile
index d508a405dc46..2a975fe04480 100644
--- a/security/bro/Makefile
+++ b/security/bro/Makefile
@@ -4,7 +4,7 @@
 # Date created:			  Sat Feb 28, 1998
 # Whom:				  David O'Brien (obrien@FreeBSD.org)
 #
-# $Id: Makefile,v 1.5 1998/09/14 00:20:20 obrien Exp $
+# $Id: Makefile,v 1.6 1998/11/04 18:45:38 obrien Exp $
 #
 
 DISTNAME=	vp-bro-0.4-alpha
@@ -16,22 +16,15 @@ MAINTAINER=     obrien@FreeBSD.org
 
 RESTRICTED=	"Author wishes Alpha releases not to be distrubted."
 
+.if !exists(${DISTDIR}/vp-bro-0.4-alpha${EXTRACT_SUFX})
+IGNORE='Please contact Vern Paxson <vern@ee.lbl.gov> to obtain the obtain the Bro source.  Put it in ${DISTDIR} as vp-bro-0.4-alpha${EXTRACT_SUFX} and run make again'
+.endif
+
 IS_INTERACTIVE=	"manual fetch"
 WRKSRC=		${WRKDIR}/bro-0.4
 CONFIGURE_ARGS= --libdir=${PREFIX}/share
 GNU_CONFIGURE=	yes
 
-do-fetch:
-	@if [ ! -f ${DISTDIR}/vp-bro-0.4-alpha${EXTRACT_SUFX} ]; then \
-	  echo ""; \
-	  echo "Please contact Vern Paxson <vern@ee.lbl.gov>"; \
-	  echo "to obtain the obtain the Bro source.  Put it in"; \
-	  echo "${DISTDIR} as vp-bro-0.4-alpha${EXTRACT_SUFX}"; \
-	  echo "and run make again"; \
-	  echo ""; \
-	  exit 1;\
-	fi
-
 post-patch:
 	@${MV} ${WRKSRC}/util.cc ${WRKSRC}/util.cc.in
 	@${SED} -e "s|/usr/src/rtsg/bro/policy:/usr/local/lib/bro|${PREFIX}/share/bro|" \
-- 
cgit v1.2.3