From 32907f0dac95d40de190cf88adcccca43adf51b9 Mon Sep 17 00:00:00 2001
From: Alex Dupre <ale@FreeBSD.org>
Date: Mon, 12 Jun 2006 16:56:35 +0000
Subject: Add support for smart cards.

Approved by:	maintainer
---
 security/openssh-portable/Makefile | 6 ++++++
 1 file changed, 6 insertions(+)

(limited to 'security')

diff --git a/security/openssh-portable/Makefile b/security/openssh-portable/Makefile
index 00c1e6b7c8f5..bc13ce810fe0 100644
--- a/security/openssh-portable/Makefile
+++ b/security/openssh-portable/Makefile
@@ -60,6 +60,7 @@ OPTIONS=	PAM		"Enable pam(3) support"			on \
 		SUID_SSH	"Enable suid SSH (Recommended off)"	off \
 		GSSAPI		"Enable GSSAPI support"			off \
 		OPENSSH_CHROOT	"Enable CHROOT support"			off \
+		OPENSC		"Enable OpenSC smartcard support"	off \
 		HPN		"Enable HPN-11 SSH/SCP patch"		off \
 		HPN_NONECIPHER	"Enable HPN-11 with None Cipher patch"	off \
 		OVERWRITE_BASE	"OpenSSH overwrite base"		off
@@ -122,6 +123,11 @@ CONFIGURE_ARGS+=	--with-ssl-dir=${OPENSSLBASE}
 CFLAGS+=		-DCHROOT
 .endif
 
+.if defined(WITH_OPENSC)
+LIB_DEPENDS+=		opensc.2:${PORTSDIR}/security/opensc
+CONFIGURE_ARGS+=	--with-opensc=${LOCALBASE}
+.endif
+
 .if defined(WITH_HPN)
 .if defined(WITH_HPN_NONECIPHER)
 IGNORE=			please, select only one HPN patch. Rerun 'make config'
-- 
cgit v1.2.3