From 216b5a285fdcc1456a307fcc60f3507c20d613eb Mon Sep 17 00:00:00 2001
From: Tijl Coosemans <tijl@FreeBSD.org>
Date: Tue, 26 Aug 2014 14:06:08 +0000
Subject: - Fix missing library problems when the linker enforces explicit
 linking

PR:		192062
Exp-run by:	antoine
Approved by:	portmgr (antoine)
---
 security/gnome-gpg/Makefile    | 1 +
 security/opensc/Makefile       | 2 +-
 security/pkcs11-dump/Makefile  | 2 +-
 security/rainbowcrack/Makefile | 4 +++-
 security/tpm-tools/Makefile    | 7 +++++--
 5 files changed, 11 insertions(+), 5 deletions(-)

(limited to 'security')

diff --git a/security/gnome-gpg/Makefile b/security/gnome-gpg/Makefile
index 3b42c8630876..1474d4f8f7bb 100644
--- a/security/gnome-gpg/Makefile
+++ b/security/gnome-gpg/Makefile
@@ -19,6 +19,7 @@ USES=		pkgconfig tar:bzip2
 GNU_CONFIGURE=	yes
 USE_GNOME=	libgnomeui
 CONFIGURE_ENV=	set_more_warnings="no"
+LIBS+=		-L${LOCALBASE}/lib -lX11
 
 PLIST_FILES=	bin/gnome-gpg \
 		man/man1/gnome-gpg.1.gz
diff --git a/security/opensc/Makefile b/security/opensc/Makefile
index 36de7a4885e4..0f18b9988e1c 100644
--- a/security/opensc/Makefile
+++ b/security/opensc/Makefile
@@ -32,7 +32,7 @@ INSTALL_TARGET=	install-strip
 
 CONFIGURE_ENV=	\
 		OPENSSL_CFLAGS="-I${OPENSSLINC}" \
-		OPENSSL_LIBS="-L${OPENSSLLIB} -lssl" \
+		OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto" \
 		XSLTPROC="${LOCALBASE}/bin/xsltproc"
 
 CONFIGURE_ARGS=	--with-xsl-stylesheetsdir=${LOCALBASE}/share/xsl/docbook
diff --git a/security/pkcs11-dump/Makefile b/security/pkcs11-dump/Makefile
index c6ace9a979d6..b57790c42f46 100644
--- a/security/pkcs11-dump/Makefile
+++ b/security/pkcs11-dump/Makefile
@@ -16,7 +16,7 @@ USE_OPENSSL=	yes
 GNU_CONFIGURE=	yes
 
 CONFIGURE_ENV=	OPENSSL_CFLAGS="-I${OPENSSLINC}" \
-		OPENSSL_LIBS="-L${OPENSSLLIB} -lssl"
+		OPENSSL_LIBS="-L${OPENSSLLIB} -lcrypto"
 
 PLIST_FILES=	bin/pkcs11-dump \
 		man/man1/pkcs11-dump.1.gz
diff --git a/security/rainbowcrack/Makefile b/security/rainbowcrack/Makefile
index d1ded4a2620b..3de108aab9e3 100644
--- a/security/rainbowcrack/Makefile
+++ b/security/rainbowcrack/Makefile
@@ -18,7 +18,9 @@ BROKEN=		does not compile on ia64, powerpc, or sparc64
 .endif
 
 post-patch:
-	@${REINPLACE_CMD} -e 's|g++|$$(CXX) $$(CXXFLAGS)|; s|\-O3||' \
+	@${REINPLACE_CMD} \
+		-e 's|g++|$$(CXX) $$(CXXFLAGS)|' -e 's|-O3||' \
+		-e 's/-lssl/-lcrypto/' \
 		${WRKSRC}/${MAKEFILE}
 
 do-install:
diff --git a/security/tpm-tools/Makefile b/security/tpm-tools/Makefile
index e903400c6282..3ee259b06cae 100644
--- a/security/tpm-tools/Makefile
+++ b/security/tpm-tools/Makefile
@@ -22,8 +22,11 @@ RUN_DEPENDS=	${LOCALBASE}/sbin/tcsd:${PORTSDIR}/security/trousers \
 
 USES=		gettext gmake iconv libtool
 USE_LDCONFIG=	YES
-USE_AUTOTOOLS=	autoconf
 GNU_CONFIGURE=	YES
-LDFLAGS+=	-L${LOCALBASE}/lib -lintl ${ICONV_LIB}
+LIBS+=		-L${LOCALBASE}/lib -lintl
+
+post-patch:
+	@${REINPLACE_CMD} '/^libtpm_unseal_la_LIBADD =/s/$$/ -lcrypto/' \
+		${WRKSRC}/lib/Makefile.in
 
 .include <bsd.port.mk>
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0