From e44a59a503d5a239df1aef1623efbad0fb8517f8 Mon Sep 17 00:00:00 2001
From: Maxim Sobolev <sobomax@FreeBSD.org>
Date: Wed, 15 Nov 2000 18:26:29 +0000
Subject: Add fidelio. Fidelio is a GNOME-based client for Hotline, a
 proprietary protocol that combines ftp-like, irc-like and news-like functions
 in one package.

---
 net/Makefile               |  1 +
 net/fidelio/Makefile       | 39 +++++++++++++++++++++++++++++++++++++++
 net/fidelio/distinfo       |  1 +
 net/fidelio/files/patch-aa | 16 ++++++++++++++++
 net/fidelio/pkg-comment    |  1 +
 net/fidelio/pkg-descr      | 24 ++++++++++++++++++++++++
 net/fidelio/pkg-plist      |  6 ++++++
 7 files changed, 88 insertions(+)
 create mode 100644 net/fidelio/Makefile
 create mode 100644 net/fidelio/distinfo
 create mode 100644 net/fidelio/files/patch-aa
 create mode 100644 net/fidelio/pkg-comment
 create mode 100644 net/fidelio/pkg-descr
 create mode 100644 net/fidelio/pkg-plist

(limited to 'net')

diff --git a/net/Makefile b/net/Makefile
index 8fd9673ab0e1..6022fecea20e 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -68,6 +68,7 @@
     SUBDIR += etherboot
     SUBDIR += ethereal
     SUBDIR += everybuddy
+    SUBDIR += fidelio
     SUBDIR += flow-tools
     SUBDIR += fping
     SUBDIR += freewais-sf
diff --git a/net/fidelio/Makefile b/net/fidelio/Makefile
new file mode 100644
index 000000000000..fd2ec3b4f9de
--- /dev/null
+++ b/net/fidelio/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for:	fidelio
+# Date created:				13 November 2000
+# Whom:					Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME=	fidelio
+PORTVERSION= 	0.9.5
+CATEGORIES=	net gnome
+MASTER_SITES=	${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=	${PORTNAME}
+
+MAINTAINER=	sobomax@FreeBSD.org
+
+LIB_DEPENDS=	xml2.5:${PORTSDIR}/textproc/libxml2
+
+XML_CONFIG?=	${LOCALBASE}/bin/xml2-config
+
+USE_X_PREFIX=	yes
+USE_GMAKE=	yes
+USE_GNOME=	yes
+GNU_CONFIGURE=	yes
+CONFIGURE_ENV=	CPPFLAGS="-I${LOCALBASE}/include `${GLIB_CONFIG} --cflags gthread`" \
+		LDFLAGS="-L${LOCALBASE}/lib `${GLIB_CONFIG} --libs gthread`" \
+		XML_CONFIG="${XML_CONFIG}"
+
+pre-patch:
+	@${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+		s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+	@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+		's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+		 s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+	@find ${WRKSRC} -type f -name "*.[ch]" | \
+		xargs ${PERL} -pi -e 's|libxml/|libxml2/|g'
+	@${PERL} -pi -e 's|libxml/|libxml2/|g ; s|-lxml|-lxml2|g' \
+		${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/net/fidelio/distinfo b/net/fidelio/distinfo
new file mode 100644
index 000000000000..4f6cdf07db04
--- /dev/null
+++ b/net/fidelio/distinfo
@@ -0,0 +1 @@
+MD5 (fidelio-0.9.5.tar.gz) = 8699e299dcc73f2ed7688310b0cde011
diff --git a/net/fidelio/files/patch-aa b/net/fidelio/files/patch-aa
new file mode 100644
index 000000000000..96bd414cf97b
--- /dev/null
+++ b/net/fidelio/files/patch-aa
@@ -0,0 +1,16 @@
+--- src/Makefile.in	2000/11/15 11:26:07	1.1
++++ src/Makefile.in	2000/11/15 11:26:24
+@@ -119,11 +119,11 @@
+ fidelio_SOURCES =  	bookmarks.c bookmarks.h 	chat.c chat.h 	files.c files.h 	filelist.c filelist.h 	filetransfer.c filetransfer.h 	guiprefs.c guiprefs.h 	guiutils.c guiutils.h 	hldat.c hldat.h hotline.h 	login.c login.h 	main.c main.h 	network.c network.h 	news.c news.h 	news15.c news15.h 	pixmap.c pixmap.h 	privchat.c privchat.h 	privs.c privs.h 	protocol.c protocol.h         server.c server.h 	smalltrans.c smalltrans.h 	tasks.c tasks.h 	threads.c threads.h 	trackers.c 	users.c users.h         userlist.c userlist.h 	userwidget.c userwidget.h
+ 
+ 
+-fidelio_LDADD = -lgthread
++fidelio_LDADD = 
+ 
+ hlforw_SOURCES = hlforw.c threads.c protocol.c network.c tasks.c guiprefs.c hldat.c pixmap.c
+ 
+-hlforw_LDADD = -lgthread
++hlforw_LDADD = 
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = ../config.h
+ CONFIG_CLEAN_FILES = 
diff --git a/net/fidelio/pkg-comment b/net/fidelio/pkg-comment
new file mode 100644
index 000000000000..b460e2a92681
--- /dev/null
+++ b/net/fidelio/pkg-comment
@@ -0,0 +1 @@
+A GNOME client for Hotline
diff --git a/net/fidelio/pkg-descr b/net/fidelio/pkg-descr
new file mode 100644
index 000000000000..14a4ce39f523
--- /dev/null
+++ b/net/fidelio/pkg-descr
@@ -0,0 +1,24 @@
+Fidelio is a GNOME client for Hotline, a proprietary protocol that combines
+ftp-like, irc-like and news-like functions in one package. 
+
+Fidelio is currently fully functional as a non-administative client, with the
+exception of banners and private chat. 
+
+Feature include: 
+ o Multiple concurrent connections;
+ o Single window per server connection;
+ o Tree-structured bookmarks;
+ o Trackers and searchable index of servers;
+ o Userlist and public chat in one pane;
+ o Private chat;
+ o Both flat (v. 1.2) and threaded news support, with posting of news;
+ o Ignore messages and chat of users;
+ o Private Messages;
+ o Sounds on events;
+ o Multiple icon set loading;
+ o Use of custom icon sets for buttons;
+ o Uploading, donwloading, resuming of file transfers;
+ o Per-donwload and per-upload bandwidth caps;
+ o Server-side and client-side file queues.
+
+WWW: http://fidelio.sourceforge.net/
diff --git a/net/fidelio/pkg-plist b/net/fidelio/pkg-plist
new file mode 100644
index 000000000000..5fe61892a5f1
--- /dev/null
+++ b/net/fidelio/pkg-plist
@@ -0,0 +1,6 @@
+bin/fidelio
+share/gnome/fidelio.default
+share/locale/el/LC_MESSAGES/fidelio.mo
+share/locale/fr/LC_MESSAGES/fidelio.mo
+share/locale/it/LC_MESSAGES/fidelio.mo
+share/locale/pt_BR/LC_MESSAGES/fidelio.mo
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0