From dc8d4f33864d5a27a6b5c71cd77fa4d46e8a4559 Mon Sep 17 00:00:00 2001
From: Alexander Langer <alex@FreeBSD.org>
Date: Wed, 19 Jul 2000 10:48:43 +0000
Subject: Add cidr-2.3, a RFC 1878 subnet calculator / helper.

PR:		20010
Submitted by:	Domas Mituzas <midom@dammit.lt>
---
 net/Makefile            |  1 +
 net/cidr/Makefile       | 24 ++++++++++++++++++++++++
 net/cidr/distinfo       |  1 +
 net/cidr/files/patch-aa | 11 +++++++++++
 net/cidr/pkg-comment    |  1 +
 net/cidr/pkg-descr      |  6 ++++++
 net/cidr/pkg-plist      |  1 +
 7 files changed, 45 insertions(+)
 create mode 100644 net/cidr/Makefile
 create mode 100644 net/cidr/distinfo
 create mode 100644 net/cidr/files/patch-aa
 create mode 100644 net/cidr/pkg-comment
 create mode 100644 net/cidr/pkg-descr
 create mode 100644 net/cidr/pkg-plist

(limited to 'net')

diff --git a/net/Makefile b/net/Makefile
index dc43f441de6b..7bea83701ffa 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -21,6 +21,7 @@
     SUBDIR += cap
     SUBDIR += centericq
     SUBDIR += choparp
+    SUBDIR += cidr
     SUBDIR += ciscoconf
     SUBDIR += citrix_ica
     SUBDIR += clog
diff --git a/net/cidr/Makefile b/net/cidr/Makefile
new file mode 100644
index 000000000000..8ea6b9e0c0d2
--- /dev/null
+++ b/net/cidr/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for:   sqsh
+# Date created:		18 Jun 2000
+# Whom:			Domas Mituzas <midom@dammit.lt>
+#
+# $FreeBSD$
+
+PORTNAME=	cidr
+PORTVERSION=	2.3
+CATEGORIES=	net
+MASTER_SITES=	http://home.netcom.com/~naym/cidr/
+DISTNAME=	cidr-current
+
+MAINTAINER=	midom@dammit.lt
+
+WRKSRC=         ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+ALL_TARGET=	cidr
+
+do-install:
+	${INSTALL_PROGRAM} ${WRKSRC}/cidr ${PREFIX}/bin/cidr
+	${INSTALL_MAN} ${WRKSRC}/cidr.1 ${PREFIX}/man/man1/cidr.1
+
+MAN1=	cidr.1
+
+.include <bsd.port.mk>
diff --git a/net/cidr/distinfo b/net/cidr/distinfo
new file mode 100644
index 000000000000..645ae8083b36
--- /dev/null
+++ b/net/cidr/distinfo
@@ -0,0 +1 @@
+MD5 (cidr-current.tar.gz) = 59b4c94b2a721a0e47973d0f79d72d91
diff --git a/net/cidr/files/patch-aa b/net/cidr/files/patch-aa
new file mode 100644
index 000000000000..063439a16695
--- /dev/null
+++ b/net/cidr/files/patch-aa
@@ -0,0 +1,11 @@
+--- Makefile.old	Wed Jul 19 12:44:39 2000
++++ Makefile	Sat Jun 17 14:26:22 2000
+@@ -4,7 +4,7 @@
+ OBJS = cidr.o
+ 
+ cidr: $(OBJS)
+-	gcc -Wall -o cidr cidr.c
++	gcc -Wall -o cidr $(OBJS)
+ 
+ clean:
+ 	rm $(OBJS) cidr
diff --git a/net/cidr/pkg-comment b/net/cidr/pkg-comment
new file mode 100644
index 000000000000..44872cd8446e
--- /dev/null
+++ b/net/cidr/pkg-comment
@@ -0,0 +1 @@
+RFC 1878 subnet calculator / helper
diff --git a/net/cidr/pkg-descr b/net/cidr/pkg-descr
new file mode 100644
index 000000000000..486dc316e448
--- /dev/null
+++ b/net/cidr/pkg-descr
@@ -0,0 +1,6 @@
+cidr is a tiny command-line tool for determining network and broadcast
+addresses a la RFC 1878.  It takes an IP address and netmask and
+outputs the network address, broadcast address, and total number of
+addresses for the corresponding subnet.  The IP can be in binary,
+decimal, hex, or dotted quad.  The mask can be in binary, decimal, hex,
+dotted quad, or prefix.
diff --git a/net/cidr/pkg-plist b/net/cidr/pkg-plist
new file mode 100644
index 000000000000..5485d27b325b
--- /dev/null
+++ b/net/cidr/pkg-plist
@@ -0,0 +1 @@
+bin/cidr
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0