From a8f7250f08f089ef63feed48db306bf87f2b49dd Mon Sep 17 00:00:00 2001
From: Tim Bishop <tdb@FreeBSD.org>
Date: Mon, 26 May 2014 16:51:57 +0000
Subject: - Set ownership with @owner and @group rather than chown.

PR:		ports/190249
Submitted by:	Krzysztof Stryjek <ports@bsdserwis.com> (maintainer)
---
 net/self-service-password/Makefile  | 5 ++++-
 net/self-service-password/pkg-plist | 2 ++
 2 files changed, 6 insertions(+), 1 deletion(-)

(limited to 'net')

diff --git a/net/self-service-password/Makefile b/net/self-service-password/Makefile
index 64416b3f8582..6e9fcaa91b24 100644
--- a/net/self-service-password/Makefile
+++ b/net/self-service-password/Makefile
@@ -3,6 +3,7 @@
 
 PORTNAME=	self-service-password
 PORTVERSION=	0.8
+PORTREVISION=	1
 CATEGORIES=	net www
 MASTER_SITES=	http://tools.ltb-project.org/attachments/download/497/
 DISTNAME=	ltb-project-${PORTNAME}-${PORTVERSION}
@@ -22,6 +23,9 @@ WANT_PHP_WEB=	yes
 CFGDIR=		conf
 CFGFILE=	config.inc.php
 
+PLIST_SUB+=	SSP_OWN=${WWWOWN}
+PLIST_SUB+=	SSP_GRP=${WWWGRP}
+
 SUB_LIST+=	PKGNAME=${PKGNAME}
 SUB_FILES=	pkg-message
 
@@ -30,6 +34,5 @@ post-extract:
 
 do-install:
 	@cd ${WRKSRC}/ && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR}/
-	@${CHOWN} -R ${WWWOWN}:${WWWGRP} ${STAGEDIR}${WWWDIR}/
 
 .include <bsd.port.mk>
diff --git a/net/self-service-password/pkg-plist b/net/self-service-password/pkg-plist
index bece8b543d18..cebdcfdd3577 100644
--- a/net/self-service-password/pkg-plist
+++ b/net/self-service-password/pkg-plist
@@ -1,3 +1,5 @@
+@owner %%SSP_OWN%%
+@group %%SSP_GRP%%
 @sample %%WWWDIR%%/conf/config.inc.php.sample
 %%WWWDIR%%/index.php
 %%WWWDIR%%/lang/ca.inc.php
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0