From 7a7daa00f1fb03960b5dc6988f35c98d38bd5515 Mon Sep 17 00:00:00 2001
From: Akinori MUSHA <knu@FreeBSD.org>
Date: Wed, 8 Nov 2000 07:48:20 +0000
Subject: Add a WITH_SASL knob that causes OpenLDAP 2 to be compiled with
 support for SASL.

Submitted by:	nectar
---
 net/openldap2/Makefile         | 17 +++++++++++++----
 net/openldap20-server/Makefile | 17 +++++++++++++----
 net/openldap20/Makefile        | 17 +++++++++++++----
 net/openldap21-server/Makefile | 17 +++++++++++++----
 net/openldap21/Makefile        | 17 +++++++++++++----
 net/openldap22-server/Makefile | 17 +++++++++++++----
 net/openldap22/Makefile        | 17 +++++++++++++----
 net/openldap23-server/Makefile | 17 +++++++++++++----
 net/openldap24-server/Makefile | 17 +++++++++++++----
 9 files changed, 117 insertions(+), 36 deletions(-)

(limited to 'net')

diff --git a/net/openldap2/Makefile b/net/openldap2/Makefile
index fc6130051da4..984b1a7d60fb 100644
--- a/net/openldap2/Makefile
+++ b/net/openldap2/Makefile
@@ -38,15 +38,24 @@ CONFIGURE_ARGS=	--localstatedir=/var/run \
 CONFIGURE_ARGS+=	--enable-wrappers
 .endif
 
-.if defined(WITH_DB2)
-BUILD_DEPENDS=	${LOCALBASE}/lib/libdb2.a:${PORTSDIR}/databases/db/
+CPPFLAGS+=	-I${LOCALBASE}/include
+LDFLAGS+=	-L${LOCALBASE}/lib
 
-CONFIGURE_ENV=	CPPFLAGS="-I${LOCALBASE}/include/db2 -D_THREAD_SAFE" \
-		LDFLAGS="-L${LOCALBASE}/lib"
+.if defined(WITH_DB2)
+BUILD_DEPENDS=	${LOCALBASE}/lib/libdb2.a:${PORTSDIR}/databases/db
+CPPFLAGS+=	-I${LOCALBASE}/include/db2 -D_THREAD_SAFE
 CONFIGURE_ARGS+=	--enable-ldbm \
 			--with-ldbm-api=db2
 .endif
 
+.if defined(WITH_SASL)
+LIB_DEPENDS=	sasl.8:${PORTSDIR}/security/cyrus-sasl
+CPPFLAGS+=	-I${LOCALBASE}/include/sasl
+.endif
+
+CONFIGURE_ENV=	CPPFLAGS="${CPPFLAGS}" \
+		LDFLAGS="${LDFLAGS}"
+
 BINS=		bin/ldapadd \
 		bin/ldapdelete \
 		bin/ldapmodify \
diff --git a/net/openldap20-server/Makefile b/net/openldap20-server/Makefile
index fc6130051da4..984b1a7d60fb 100644
--- a/net/openldap20-server/Makefile
+++ b/net/openldap20-server/Makefile
@@ -38,15 +38,24 @@ CONFIGURE_ARGS=	--localstatedir=/var/run \
 CONFIGURE_ARGS+=	--enable-wrappers
 .endif
 
-.if defined(WITH_DB2)
-BUILD_DEPENDS=	${LOCALBASE}/lib/libdb2.a:${PORTSDIR}/databases/db/
+CPPFLAGS+=	-I${LOCALBASE}/include
+LDFLAGS+=	-L${LOCALBASE}/lib
 
-CONFIGURE_ENV=	CPPFLAGS="-I${LOCALBASE}/include/db2 -D_THREAD_SAFE" \
-		LDFLAGS="-L${LOCALBASE}/lib"
+.if defined(WITH_DB2)
+BUILD_DEPENDS=	${LOCALBASE}/lib/libdb2.a:${PORTSDIR}/databases/db
+CPPFLAGS+=	-I${LOCALBASE}/include/db2 -D_THREAD_SAFE
 CONFIGURE_ARGS+=	--enable-ldbm \
 			--with-ldbm-api=db2
 .endif
 
+.if defined(WITH_SASL)
+LIB_DEPENDS=	sasl.8:${PORTSDIR}/security/cyrus-sasl
+CPPFLAGS+=	-I${LOCALBASE}/include/sasl
+.endif
+
+CONFIGURE_ENV=	CPPFLAGS="${CPPFLAGS}" \
+		LDFLAGS="${LDFLAGS}"
+
 BINS=		bin/ldapadd \
 		bin/ldapdelete \
 		bin/ldapmodify \
diff --git a/net/openldap20/Makefile b/net/openldap20/Makefile
index fc6130051da4..984b1a7d60fb 100644
--- a/net/openldap20/Makefile
+++ b/net/openldap20/Makefile
@@ -38,15 +38,24 @@ CONFIGURE_ARGS=	--localstatedir=/var/run \
 CONFIGURE_ARGS+=	--enable-wrappers
 .endif
 
-.if defined(WITH_DB2)
-BUILD_DEPENDS=	${LOCALBASE}/lib/libdb2.a:${PORTSDIR}/databases/db/
+CPPFLAGS+=	-I${LOCALBASE}/include
+LDFLAGS+=	-L${LOCALBASE}/lib
 
-CONFIGURE_ENV=	CPPFLAGS="-I${LOCALBASE}/include/db2 -D_THREAD_SAFE" \
-		LDFLAGS="-L${LOCALBASE}/lib"
+.if defined(WITH_DB2)
+BUILD_DEPENDS=	${LOCALBASE}/lib/libdb2.a:${PORTSDIR}/databases/db
+CPPFLAGS+=	-I${LOCALBASE}/include/db2 -D_THREAD_SAFE
 CONFIGURE_ARGS+=	--enable-ldbm \
 			--with-ldbm-api=db2
 .endif
 
+.if defined(WITH_SASL)
+LIB_DEPENDS=	sasl.8:${PORTSDIR}/security/cyrus-sasl
+CPPFLAGS+=	-I${LOCALBASE}/include/sasl
+.endif
+
+CONFIGURE_ENV=	CPPFLAGS="${CPPFLAGS}" \
+		LDFLAGS="${LDFLAGS}"
+
 BINS=		bin/ldapadd \
 		bin/ldapdelete \
 		bin/ldapmodify \
diff --git a/net/openldap21-server/Makefile b/net/openldap21-server/Makefile
index fc6130051da4..984b1a7d60fb 100644
--- a/net/openldap21-server/Makefile
+++ b/net/openldap21-server/Makefile
@@ -38,15 +38,24 @@ CONFIGURE_ARGS=	--localstatedir=/var/run \
 CONFIGURE_ARGS+=	--enable-wrappers
 .endif
 
-.if defined(WITH_DB2)
-BUILD_DEPENDS=	${LOCALBASE}/lib/libdb2.a:${PORTSDIR}/databases/db/
+CPPFLAGS+=	-I${LOCALBASE}/include
+LDFLAGS+=	-L${LOCALBASE}/lib
 
-CONFIGURE_ENV=	CPPFLAGS="-I${LOCALBASE}/include/db2 -D_THREAD_SAFE" \
-		LDFLAGS="-L${LOCALBASE}/lib"
+.if defined(WITH_DB2)
+BUILD_DEPENDS=	${LOCALBASE}/lib/libdb2.a:${PORTSDIR}/databases/db
+CPPFLAGS+=	-I${LOCALBASE}/include/db2 -D_THREAD_SAFE
 CONFIGURE_ARGS+=	--enable-ldbm \
 			--with-ldbm-api=db2
 .endif
 
+.if defined(WITH_SASL)
+LIB_DEPENDS=	sasl.8:${PORTSDIR}/security/cyrus-sasl
+CPPFLAGS+=	-I${LOCALBASE}/include/sasl
+.endif
+
+CONFIGURE_ENV=	CPPFLAGS="${CPPFLAGS}" \
+		LDFLAGS="${LDFLAGS}"
+
 BINS=		bin/ldapadd \
 		bin/ldapdelete \
 		bin/ldapmodify \
diff --git a/net/openldap21/Makefile b/net/openldap21/Makefile
index fc6130051da4..984b1a7d60fb 100644
--- a/net/openldap21/Makefile
+++ b/net/openldap21/Makefile
@@ -38,15 +38,24 @@ CONFIGURE_ARGS=	--localstatedir=/var/run \
 CONFIGURE_ARGS+=	--enable-wrappers
 .endif
 
-.if defined(WITH_DB2)
-BUILD_DEPENDS=	${LOCALBASE}/lib/libdb2.a:${PORTSDIR}/databases/db/
+CPPFLAGS+=	-I${LOCALBASE}/include
+LDFLAGS+=	-L${LOCALBASE}/lib
 
-CONFIGURE_ENV=	CPPFLAGS="-I${LOCALBASE}/include/db2 -D_THREAD_SAFE" \
-		LDFLAGS="-L${LOCALBASE}/lib"
+.if defined(WITH_DB2)
+BUILD_DEPENDS=	${LOCALBASE}/lib/libdb2.a:${PORTSDIR}/databases/db
+CPPFLAGS+=	-I${LOCALBASE}/include/db2 -D_THREAD_SAFE
 CONFIGURE_ARGS+=	--enable-ldbm \
 			--with-ldbm-api=db2
 .endif
 
+.if defined(WITH_SASL)
+LIB_DEPENDS=	sasl.8:${PORTSDIR}/security/cyrus-sasl
+CPPFLAGS+=	-I${LOCALBASE}/include/sasl
+.endif
+
+CONFIGURE_ENV=	CPPFLAGS="${CPPFLAGS}" \
+		LDFLAGS="${LDFLAGS}"
+
 BINS=		bin/ldapadd \
 		bin/ldapdelete \
 		bin/ldapmodify \
diff --git a/net/openldap22-server/Makefile b/net/openldap22-server/Makefile
index fc6130051da4..984b1a7d60fb 100644
--- a/net/openldap22-server/Makefile
+++ b/net/openldap22-server/Makefile
@@ -38,15 +38,24 @@ CONFIGURE_ARGS=	--localstatedir=/var/run \
 CONFIGURE_ARGS+=	--enable-wrappers
 .endif
 
-.if defined(WITH_DB2)
-BUILD_DEPENDS=	${LOCALBASE}/lib/libdb2.a:${PORTSDIR}/databases/db/
+CPPFLAGS+=	-I${LOCALBASE}/include
+LDFLAGS+=	-L${LOCALBASE}/lib
 
-CONFIGURE_ENV=	CPPFLAGS="-I${LOCALBASE}/include/db2 -D_THREAD_SAFE" \
-		LDFLAGS="-L${LOCALBASE}/lib"
+.if defined(WITH_DB2)
+BUILD_DEPENDS=	${LOCALBASE}/lib/libdb2.a:${PORTSDIR}/databases/db
+CPPFLAGS+=	-I${LOCALBASE}/include/db2 -D_THREAD_SAFE
 CONFIGURE_ARGS+=	--enable-ldbm \
 			--with-ldbm-api=db2
 .endif
 
+.if defined(WITH_SASL)
+LIB_DEPENDS=	sasl.8:${PORTSDIR}/security/cyrus-sasl
+CPPFLAGS+=	-I${LOCALBASE}/include/sasl
+.endif
+
+CONFIGURE_ENV=	CPPFLAGS="${CPPFLAGS}" \
+		LDFLAGS="${LDFLAGS}"
+
 BINS=		bin/ldapadd \
 		bin/ldapdelete \
 		bin/ldapmodify \
diff --git a/net/openldap22/Makefile b/net/openldap22/Makefile
index fc6130051da4..984b1a7d60fb 100644
--- a/net/openldap22/Makefile
+++ b/net/openldap22/Makefile
@@ -38,15 +38,24 @@ CONFIGURE_ARGS=	--localstatedir=/var/run \
 CONFIGURE_ARGS+=	--enable-wrappers
 .endif
 
-.if defined(WITH_DB2)
-BUILD_DEPENDS=	${LOCALBASE}/lib/libdb2.a:${PORTSDIR}/databases/db/
+CPPFLAGS+=	-I${LOCALBASE}/include
+LDFLAGS+=	-L${LOCALBASE}/lib
 
-CONFIGURE_ENV=	CPPFLAGS="-I${LOCALBASE}/include/db2 -D_THREAD_SAFE" \
-		LDFLAGS="-L${LOCALBASE}/lib"
+.if defined(WITH_DB2)
+BUILD_DEPENDS=	${LOCALBASE}/lib/libdb2.a:${PORTSDIR}/databases/db
+CPPFLAGS+=	-I${LOCALBASE}/include/db2 -D_THREAD_SAFE
 CONFIGURE_ARGS+=	--enable-ldbm \
 			--with-ldbm-api=db2
 .endif
 
+.if defined(WITH_SASL)
+LIB_DEPENDS=	sasl.8:${PORTSDIR}/security/cyrus-sasl
+CPPFLAGS+=	-I${LOCALBASE}/include/sasl
+.endif
+
+CONFIGURE_ENV=	CPPFLAGS="${CPPFLAGS}" \
+		LDFLAGS="${LDFLAGS}"
+
 BINS=		bin/ldapadd \
 		bin/ldapdelete \
 		bin/ldapmodify \
diff --git a/net/openldap23-server/Makefile b/net/openldap23-server/Makefile
index fc6130051da4..984b1a7d60fb 100644
--- a/net/openldap23-server/Makefile
+++ b/net/openldap23-server/Makefile
@@ -38,15 +38,24 @@ CONFIGURE_ARGS=	--localstatedir=/var/run \
 CONFIGURE_ARGS+=	--enable-wrappers
 .endif
 
-.if defined(WITH_DB2)
-BUILD_DEPENDS=	${LOCALBASE}/lib/libdb2.a:${PORTSDIR}/databases/db/
+CPPFLAGS+=	-I${LOCALBASE}/include
+LDFLAGS+=	-L${LOCALBASE}/lib
 
-CONFIGURE_ENV=	CPPFLAGS="-I${LOCALBASE}/include/db2 -D_THREAD_SAFE" \
-		LDFLAGS="-L${LOCALBASE}/lib"
+.if defined(WITH_DB2)
+BUILD_DEPENDS=	${LOCALBASE}/lib/libdb2.a:${PORTSDIR}/databases/db
+CPPFLAGS+=	-I${LOCALBASE}/include/db2 -D_THREAD_SAFE
 CONFIGURE_ARGS+=	--enable-ldbm \
 			--with-ldbm-api=db2
 .endif
 
+.if defined(WITH_SASL)
+LIB_DEPENDS=	sasl.8:${PORTSDIR}/security/cyrus-sasl
+CPPFLAGS+=	-I${LOCALBASE}/include/sasl
+.endif
+
+CONFIGURE_ENV=	CPPFLAGS="${CPPFLAGS}" \
+		LDFLAGS="${LDFLAGS}"
+
 BINS=		bin/ldapadd \
 		bin/ldapdelete \
 		bin/ldapmodify \
diff --git a/net/openldap24-server/Makefile b/net/openldap24-server/Makefile
index fc6130051da4..984b1a7d60fb 100644
--- a/net/openldap24-server/Makefile
+++ b/net/openldap24-server/Makefile
@@ -38,15 +38,24 @@ CONFIGURE_ARGS=	--localstatedir=/var/run \
 CONFIGURE_ARGS+=	--enable-wrappers
 .endif
 
-.if defined(WITH_DB2)
-BUILD_DEPENDS=	${LOCALBASE}/lib/libdb2.a:${PORTSDIR}/databases/db/
+CPPFLAGS+=	-I${LOCALBASE}/include
+LDFLAGS+=	-L${LOCALBASE}/lib
 
-CONFIGURE_ENV=	CPPFLAGS="-I${LOCALBASE}/include/db2 -D_THREAD_SAFE" \
-		LDFLAGS="-L${LOCALBASE}/lib"
+.if defined(WITH_DB2)
+BUILD_DEPENDS=	${LOCALBASE}/lib/libdb2.a:${PORTSDIR}/databases/db
+CPPFLAGS+=	-I${LOCALBASE}/include/db2 -D_THREAD_SAFE
 CONFIGURE_ARGS+=	--enable-ldbm \
 			--with-ldbm-api=db2
 .endif
 
+.if defined(WITH_SASL)
+LIB_DEPENDS=	sasl.8:${PORTSDIR}/security/cyrus-sasl
+CPPFLAGS+=	-I${LOCALBASE}/include/sasl
+.endif
+
+CONFIGURE_ENV=	CPPFLAGS="${CPPFLAGS}" \
+		LDFLAGS="${LDFLAGS}"
+
 BINS=		bin/ldapadd \
 		bin/ldapdelete \
 		bin/ldapmodify \
-- 
cgit debian/1.2.3+git2.25.1-1-2-gaceb0